Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите написать программу на паскале АВС. светофор переключается каждые 10 секунд. В 0 часов 0 минут 0 секунд горит зелёный. какой цвет будет гореть чер

10-11 класс

ез 4 часа 5 минут 23 секунды

Vika1591 07 нояб. 2015 г., 3:58:05 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mingazov1995
07 нояб. 2015 г., 6:28:55 (8 лет назад)

var
  timeInSec:integer; // время в секундах
  color, s, m, h:byte;
begin
  h := 4; //часы
  m := 5; //минуты
  s := 23; //секунды

  timeInSec := h * 3600 + m * 60 + s; //перевод времени в секунды
  color := (timeInSec div 10) mod 3; {целочисленно делим на 10, чтобы узнать сколько раз светофор изменил цвет}
  {потом находим остаток деления на 3(количество цветов), чтобы узнать какой сейчас   цвет}
  case color of //вывод ответа
    0: writeln('Горит зеленый свет'); //0 - это зеленый свет
    1: writeln('Горит желтый свет'); //1 - это желтый свет
    2: writeln('Горит красный свет'); //2 - это крсный свет
  end;
end.

Ответить

Другие вопросы из категории

Ребят, пожалуйста, напишите программу. Паскаль

"Составить программу вычисления y=1+(x/1)-((x^3)/3)+((x^5)/5)-.......+((x^15)/15) при изменении аргумента x в интервале 2<=x<=8. С шагом h=1

Помогите пожалуйста, завтра экзамен!

С клавиатуры вводятся вещественные числа. Признак конца ввода - 0. Определить, является ли вводимая последовательность упорядоченной по невозрастанию или по неубыванию (PascalABC).

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму



Вы находитесь на странице вопроса "помогите написать программу на паскале АВС. светофор переключается каждые 10 секунд. В 0 часов 0 минут 0 секунд горит зелёный. какой цвет будет гореть чер", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.