Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите плиз нужно

10-11 класс

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.

F(x) = 2 cos x - 1.

ойи 05 авг. 2013 г., 23:20:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Acmodey
06 авг. 2013 г., 1:09:55 (10 лет назад)

var
  a,b,h,x,y:real;
begin
  writeln('Введите начальное значение, шаг и конечное значение');
  readln(a,h,b);
  x:=a;
  while x<=b do begin
    y:=2*cos(x)-1;
    writeln(x:10:3,y:10:6);
    x:=x+h
  end
end.

Тестовый прогон:

Введите начальное значение, шаг и конечное значение
-5 1 5
    -5.000 -0.432676
    -4.000 -2.307287
    -3.000 -2.979985
    -2.000 -1.832294
    -1.000  0.080605
     0.000  1.000000
     1.000  0.080605
     2.000 -1.832294
     3.000 -2.979985
     4.000 -2.307287
     5.000 -0.432676



+ 0 -
Anna17tu
06 авг. 2013 г., 3:33:14 (10 лет назад)

на каком языке?

+ 0 -
Annivanova04
06 авг. 2013 г., 4:09:59 (10 лет назад)

в паскале ABC

Ответить

Читайте также

Помогите плиииз=)

Привет. Помогите плиз=)
№1)Составить алгоритм вывода среднего(не арифметического) из трёх чисел в виде блок-схемы.
Входные данные:три числа
Выходные данные:среднее число

№2) На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

Помогите плиз решить ничего не понимаю заранее спасибо

1.Сколько раз будет выполнена команда повторения в приведенных фрагментах при n=7:
1) for i :=n downto 4 do;
2)S:=S * i.
2. Определите, какой будет результат приведенного фрагмента: a:=100, n:=4:
for i:=1 to n do
a:=a - 2 * i.
Очень важно помогите.

1)Загадано число от 1 до 100.Загадавший на все вопросы отвечает только "да" или "нет".Какое наименьшее число вопросов нужно задать, чтобы

гарантированно угадать число? 2)В велокроссе участвуют 119 спорстменов.Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием минимально возможного количества бит, одинакового для каждого спортсмена.Каков информационный объем в битах сообщения, записанного устройством, после того как промежуточный финиш прошли 70 велосипедистов? Помогите пожалуйста, нужно решение как можно скорее!

Помогите, очень нужно.

Нужно найти переменную i



Вы находитесь на странице вопроса "Помогите плиз нужно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.