Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

с 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. известно что в течении этого времени температура

10-11 класс

понижалась . напишите программу, определяющую , в котором часу была впервые отмечена отрицательная температура .

Lfirsova 07 окт. 2014 г., 4:17:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aryslanovbaklan
07 окт. 2014 г., 6:16:26 (9 лет назад)

program temp;
uses crt;
var
tem:array [8..20] of real;
min:real;
i:integer;
begin

for i:=8 to 20 do
begin
clrscr;
writeln('Vvedite temperaturu dlya ',i,' chasa zamera');
read(tem[i]);
end;

for i:=8 to 20 do if tem[i]<0 then min:=i;
writeln('Vpervue otricatelnaya temperatura otmechena v ',min);
readln;

end.


+ 0 -
Dmitrii
12 мая 2018 г., 7:54:02 (6 лет назад)

uses crt; var tem:array [8..20] of integer; min:integer; i,p:integer; begin min:=0; p:=0; for i:=8 to 20 do begin tem[i]:=Random(5)-5+2; end; for i:=8 to 20 do begin writeln(' Время= ',i,' температура ',tem[i]); if min0 then p:=p+1 else if tem[i]=1 then begin i:=min; writeln('В первые отрицательная погода отмечена в ',min, ' часов составляла ', tem[i]); end else writeln('Отрицательной погоды не было'); end.

Ответить

Другие вопросы из категории

компьютерный вирус А заполняет 1 Гбайт за 1 месяц, вирус В заполняет 1 Гбайт за 2 месяца, вирус С заполняет 1 Гбайт за 3 месяца, вирус D заполняет 1

Гбайт за 6 месяцев. На компе обнаружено сразу 4 вируса. Через какое время на 1 Гбайт памяти не останется области, не заполненной вирусами?
1) четверть месяца
2) половина месяца
3) один месяц
4) два месяца
5) три месяца

Помогите решить!!! Уже всю голову сломал, думая над этой задачей.

Если город представить в виде двумерного массива, то получается, что в каждом квартале (ячейке массива) может стоять либо Маша, либо камера (или несколько камер). Посчитать манхтэнское расстояние(сумма расстояний от Маши до всех камер) по формуле:
R= |x1-x2|+|y1-y2|.
Первоначальные координаты Маши (0,0).
Формат ввода:
Первая строка содержит N кол-во камер в городе и M шагов Маши. Вторая строка - координаты камер (х,y).
Для описания передвижения Маши с клавиатуры вводится символы U,D,R,L. Каждый из них означает:
U- увеличить координату у на 1.
D - уменьшить эту же координату.
L - уменьшить координату х.
R - увеличить координату х.
Выводить манхтэнское расстояние для каждого шага Маши.
Пример:
Ввод:___ Вывод:
1 3_______11
0 -10_____12
RUR _____13

помогите с вопросом:

устройство для чтения/записи данных с внешнего носителя

Читайте также

Задачи на массив в Turbo Pascal

1) Определите ,на сколько отличается рост самого высокого и самого низкого учащегося в классе?
2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива -год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.
3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20)

до 20.Найдите среднюю температуру по тем дням, когда она была выше нуля.(язык программирования Бейсик)

Дан одномерный массив из 10 элементов. Элементы массива лежат в диапазоне от -20 до 20 и обозначают температуру первой декады (10 дней) марта. Определите

номера дней, когда температура опускалась ниже -10. Напишите программу, которая позволяет найти и вывести номера дней, когда температура опускалась ниже -10.

метеорологическая станция ведет наблюдение за температурой воздуха. результатом одного измерения является целое число принимающее значение от 720 до 780мм

ртутного столба,которое записывается при помощи минимального возможного количества бит.станция сделала 80 измерений.каков информационный объем результатов наблюдений?



Вы находитесь на странице вопроса "с 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. известно что в течении этого времени температура", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.