Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

№1

10-11 класс

Даны два действительных числа, не равные друг другу. Меньшее из этих двух чисел заменить половинной их суммы, а большее-их удвоенным произведением.
№2
Определить корректность введенной даты(число-от 1 до 31, месяц-от 1 до 12). Если введены неверные данные, то сообщить об этом.
№3
Написать программу, которая находит наибольшее из трех введенных чисел и выводит его на экран.

Yadamir 24 янв. 2016 г., 19:36:25 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
OlivKafddt
24 янв. 2016 г., 21:17:23 (8 лет назад)

1)

var

a,b,x,y:real;

begin

readln(a,b);

x:=(a+b)/2;

y:=2*a*b;

if a>b then

begin

a:=y;

b:=x;

end

else

begin

a:=x;

b:=y;

end;

writeln('a=',a:8:3);

writeln('b=',b:8:3);

end.

2)

var

d,m:integer;

begin

readln(d,m);

if (d<1) or (d>31) then writeln ('день введен неверно');

if (m<1) or (m>12) then writeln ('месяц введен неверно');

end.

3)

var 

a,b,c:integer;

begin

readln(a,b,c);

if (a>b) and (a>c) then writeln(a);

if (b>a) and (b>c) then writeln(b);

if (c>a) and (c>b) then writeln(c);

end.

+ 0 -
35953
24 янв. 2016 г., 22:14:03 (8 лет назад)

1)

var a,b,c,d:real;

begin

  read(a,b);

  c:=(a+b)/2;

  d:=2*a*b;

  if a>b then begin

   a:=d;

   b:=c;

  end;

  if a<b then begin

  a:=c;

  b:=d;

  end;

  writeln(a,' ',b);

end.

 

2)

var a,b:integer;

begin

  read(a,b);

  if (a<1) or (a>31) then writeln(' день введен неправильно');

  if (b<1) or (b>12) then writeln(' месяц введен неправильно');

end.

 

3)

var a,b,c:real;

begin

  read(a,b,c);

  if (a>b)and(a>c)then writeln(a); 

  if (b>a)and(b>c)then writeln(b);

  if (c>b)and(c>a)then writeln(c);

end.

Ответить

Другие вопросы из категории

Что больше 8000 Кб или 6 Мб?
В некоторой информационной системе информация кодируется двоичными шестиразрядными словами. При передаче данных возможны их искажения, поэтому в конец

каждого слова добавляется седьмой (контрольный) разряд, таким образом, чтобы сумма разрядов нового слова, считая контрольный, была чётной. Например, к слову 110011 справа будет добавлен 0, а к слову 101100 — 1. После приёма слова производится его обработка. При этом проверяется сумма его разрядов, включая контрольный. Если она нечётна, это означает, что при передаче этого слова произошёл сбой, и оно автоматически заменяется на зарезервированное слово 0000000. Если чётна — слово не изменяется. Исходное сообщение: 1111101 0011000 1011100 было принято в виде: 1111101 0011100 1000100 Как будет выглядеть сообщение после обработки? 1)0000000 0011100 1000100 2)1111101 0000000 0000000 3)1111101 0011100 0000000 4)1111101 0000000 1000100 Желательно с решением и объяснением!

Пожалуйста, помогите! Это срочно.

Составила алгоритм и заполнила таблицу, а исправить ошибку не получается.

Читайте также



Вы находитесь на странице вопроса "№1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.