Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

найти номер строки и номер столбца максимального элемента матрицы, в delphi

10-11 класс

Nactya08 09 февр. 2016 г., 15:51:20 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ekaterina310tim
09 февр. 2016 г., 16:33:20 (8 лет назад)

var a,i,j,b,p,p1,max:longint;
m:array[0..501,1..500] of longint;
begin
read(a,b);
for i:=1 to a do
for j:=1 to b do
read(m[i,j]);
p:=1;
p1:=1;
max:=m[1,1];
for i:=1 to a do
for j:=1 to b do
if m[i,j]>max then
begin
p:=i;
p1:=j;
max:=m[i,j];
end;
writeln(p,' ',p1);
end.

Ответить

Другие вопросы из категории

1) Световое табло состоит из лампочек. Каждая лампочка может находиться в одном из трех состояний («включено», «выключено» или «мигает»). Какое

наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 18 различных сигналов?

2) Сколько существует различных последовательностей из символов «плюс» и «минус», длиной ровно в пять символов?

3) Шахматная доска состоит 8 столбцов и 8 строк. Какое минимальное количество бит потребуется для кодирования координат одного шахматного поля?

4) Какое минимальное количество бит потребуется для кодирования положительных чисел, меньших 60?

5) Двое играют в «крестики-нолики» на поле 4 на 4 клетки. Какое количество информации (в битах) получил второй игрок, узнав ход первого игрока?

№1

Даны два действительных числа, не равные друг другу. Меньшее из этих двух чисел заменить половинной их суммы, а большее-их удвоенным произведением.
№2
Определить корректность введенной даты(число-от 1 до 31, месяц-от 1 до 12). Если введены неверные данные, то сообщить об этом.
№3
Написать программу, которая находит наибольшее из трех введенных чисел и выводит его на экран.

Что больше 8000 Кб или 6 Мб?
В некоторой информационной системе информация кодируется двоичными шестиразрядными словами. При передаче данных возможны их искажения, поэтому в конец

каждого слова добавляется седьмой (контрольный) разряд, таким образом, чтобы сумма разрядов нового слова, считая контрольный, была чётной. Например, к слову 110011 справа будет добавлен 0, а к слову 101100 — 1. После приёма слова производится его обработка. При этом проверяется сумма его разрядов, включая контрольный. Если она нечётна, это означает, что при передаче этого слова произошёл сбой, и оно автоматически заменяется на зарезервированное слово 0000000. Если чётна — слово не изменяется. Исходное сообщение: 1111101 0011000 1011100 было принято в виде: 1111101 0011100 1000100 Как будет выглядеть сообщение после обработки? 1)0000000 0011100 1000100 2)1111101 0000000 0000000 3)1111101 0011100 0000000 4)1111101 0000000 1000100 Желательно с решением и объяснением!

Читайте также

Помогите решить, пожалуйста! Хотя бы некоторые задачи.

1. Найти сумму (произведение) элементов 1-й строки (столбца) массива Т (6,4).
2. Заполните матрицу, элементами которой является произведение номеров строк и столбцов соответствующих элементов.
3. Вычислить сумму и произведения элементов матрицы Z (4,6).
4. Вычислить сумму и произведение элементов матрицы А(5,5).
Язык программирования - Pascal.

Помогите пожалуйста решить))) или хотя бы натолкнуть на мысль )) 1) Записать элементы массива Х, удовлетворяющие условию 1≤Xi≤2, подряд в массив

Y. Поменять местами максимальный и минимальный элементы в массиве Y.

2) Заменить строку матрицы Р(n,m) с минимальной суммой элементов на строк, где находится максимальный элементы матрицы.

3) Определить, пересекаются ли параболы у=ах2+bc+c и y=dx2+mx+n. Если пересекаются, то найти точку пересечения.

помогите пожалуйста решить в паскале. Создайте двухмерный массив Х, имеющий четыре строки и три столбца, и найдите в нем максимальный по абсолютному

значению элемент, а также номера строки и столбца, содержащих этот элемент. Например, в массиве, показанном справа, максимальный по абсолютному значению элемент равен 8, он находится во 2-й строке 3-го столбца.

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "найти номер строки и номер столбца максимального элемента матрицы, в delphi", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.