Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

(35 БАЛЛОВ!!!)Составить программу, которая по координатам точки(x,y) пересечения прямых, разрезающих квадрат со стороной p вычисляет отношение сторон

5-9 класс

полученных
прямоугольников (a/b,a1/b1,a2/b2,a3/b3)

Vladi006 03 июля 2013 г., 19:04:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kisska2002
03 июля 2013 г., 20:03:56 (10 лет назад)

var
  p, x, y, a1, a2, b1, b2: real;

begin
  Write('Введите через пробел координаты x,y точки: ');
  Readln(x, y);
  Write('Введите длину стороны квадрата: ');
  Readln(p);
  a1 := x; a2 := p - x;
  b1 := y; b2 := p - y;
  Writeln('a1/b1=', a1 / b1:0:4);
  Writeln('a1/b2=', a1 / b2:0:4);
  Writeln('a2/b1=', a2 / b1:0:4);
  Writeln('a2/b2=', a2 / b2:0:4)
end.

Тестовое решение:

Введите через пробел координаты x,y точки: 4 8.5
Введите длину стороны квадрата: 15
a1/b1=0.4706
a1/b2=0.6154
a2/b1=1.2941
a2/b2=1.6923



+ 0 -
PolinaRyb
03 июля 2013 г., 22:52:37 (10 лет назад)

Непонятно, где эти a,a1,a2,,, и т.п.

Ответить

Другие вопросы из категории

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них



Вы находитесь на странице вопроса "(35 БАЛЛОВ!!!)Составить программу, которая по координатам точки(x,y) пересечения прямых, разрезающих квадрат со стороной p вычисляет отношение сторон", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.