Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

С клавиатуры вводятся последовательность из n целых чисел сколько чисел кратных числу p

5-9 класс

SkypeFrinter 31 авг. 2013 г., 11:30:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizavaleeva98
31 авг. 2013 г., 14:06:18 (10 лет назад)

var n,p,k,s,i:integer;
begin 
writeln(n); 
readln(n); 
writeln(p); 
readln(p); 
s:=0; 
for i:=1 to n do 
begin 
writeln('введи число'); 
readln(k); 
if (k mod p =0) then s:=s+1; 
end; 
writeln('ответ ',s); 
end.

Ответить

Другие вопросы из категории

Решите пожалуйста!!!
ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции

деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы



Вы находитесь на странице вопроса "С клавиатуры вводятся последовательность из n целых чисел сколько чисел кратных числу p", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.