Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

дано натуральное число n и действительное число x .разработать схему алгоритма для вычисления суммы ряда: sinx + sin 2x

5-9 класс

+sin3x+...+sinn*x.Протестировать алгоритм для х=1,5 и n=3

Sionidenis 28 янв. 2015 г., 5:54:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЛоЛОЛКа
28 янв. 2015 г., 6:53:49 (9 лет назад)

var
i, n: integer;
x, rez: real;

begin
readln(x, n);
for i:=1 to n do
 rez:=rez+sin(i*x)
write(rez);
end.

Если возникнут вопросы или будут ошибки в ходе работы программы, пиши ниже.

Ответить

Другие вопросы из категории

Читайте также

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "дано натуральное число n и действительное число x .разработать схему алгоритма для вычисления суммы ряда: sinx + sin 2x", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.