Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Написать программу в Pascal, используя массивы.

10-11 класс

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк

Ibragim201525 26 марта 2015 г., 11:01:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Milenochkam
26 марта 2015 г., 12:20:33 (9 лет назад)

const
  n = 100;

var
  a: array[1..n] of integer;
  i: integer;

begin
  //заполняем массив случайными значениями в диапазоне [0;100]
  Randomize; //инициализация датчика случайных чисел
  for i := 1 to n do a[i] := random(100);
  i := 1;  //1 - это два в нулевой степени
  while i < n do
  begin
    writeln('a(', i, ')=', a[i]);
    i := 2 * i;  //удваиваем индекс, чтобы получить очередную степень двойки
  end
end.

Результат работы программы:
a(1)=26
a(2)=21
a(4)=29
a(8)=74
a(16)=23
a(32)=44
a(64)=20


Ответить

Другие вопросы из категории

4. Сколько различных звуковых сигналов можно закодировать с помощью 8 бит? 5. Сколько нужно бит, чтобы закодировать алфавит из 64 символов? 6. Когда Вы

подошли к светофору, горел желтый свет. Затем зажегся красный. Какой объем информации Вы получили в момент, когда зажегся красный?

Проверьте, делится ли выбранное число на 5, на 11 или 13

нужно сделать в Pascal ABC

Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Алгоритм поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них). Пишите программу целиком

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Задание:
Дан массив целых чисел. Найти сумму положительных нечетных. Обязательно по процедурам с массивами



Вы находитесь на странице вопроса "Написать программу в Pascal, используя массивы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.