Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

программа паскаль: выступают 3 спортсмена по прыжкам в высоту и нужно найти кто из них прыгнул выше,используя массив,числа в рандомном порядке выходят у

10-11 класс

спортсменов от 1,80 до 2,46

Leovital 05 сент. 2013 г., 16:25:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gribovskay
05 сент. 2013 г., 16:58:29 (10 лет назад)

var a:array[1..3] of real;
i,m:integer;
begin
m:=1;
for i:=1 to 3 do begin
a[i]:=(random(67)+180)/100;
if a[i]>a[m] then m:=i;
end;
writeln(a[m]);
end.

Ответить

Другие вопросы из категории

что нужно сделать чтобы работал либо ручной ввод либо рандом

program lab7;
var x: array [1..100] of real;
i: integer;
s: real;
n:=53;
begin
cls;
s:=0;
writeln ('Введите элементы массива:');
for i:=1 to n do beginwrite ('x[',i,']=');
readln (x[i]);
s:=s+x[i];
end;
writeln ('Полученная сумма равна ', s);
begin
for i:=1 to n do
begin
x[i]:=random(100);
write(x[i]:5);
s:=s+x[i];
end;
writeln;
writeln ('Полученная сумма равна ', s);
end;
end.

Продавец зоомагазина уверял покупателя,что купленный им попугай будет повторять каждое услышанное слово. Каково же было удивление покупателя,когда он

убедился,что попугай нем,как рыба. Тем не менее продавец не лгал. Объясните,как это могло быть

Есть код на паскале, который считает выражение и запрещает ввод букв. Нужно сделать проверку знаменателя на 0 обоих выражений, и вывести текст в случае

нуля

PascalABC

program aip;
var
fltA,fltB,fltB2:real;
code:integer;
function ip(A:real):real;
var A1:string;
begin
write('Введите значение А= ');


//--------
repeat
readln(A1);
val(A1,A,code);
if (code<>0) then writeln('no');
until (A>0);
//-------
ip:=A;
end;
begin
fltA:=ip(fltA);
fltB:= ((1-2*sin(fltA)*sin(fltA))/(1+sin(2*fltA)));
fltB2:= ((1-tan(fltA))/(1+tan(fltA)));
writeln('Первая формула ',fltB:5:5);
writeln('Вторая формула ',fltB2:5:5);
end.

Дано натуральное число n. Вычислить P = (1-

 \frac{1}{2 ^{2} } )(1- \frac{1}{3 ^{2} } ) ... (1- \frac{1}{n ^{2} } ) , где n> 2 . Если можно, то напишите на языке ПАСКАЛЯ.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Четыре приятеля (Ильдус, Мансур, Алмаз и Рамиль) – спортсмены: футболист, велосипедист, теннисист и шахматист. Определите, кто из них каким видом

спорта занимается, если Вам известно следующее:

1. Футболист читает только газету «Спорт» и убеждённый холостяк.

2.Шахматист пьёт только коньяк и убеждённый реформатор.

3.Теннисист недавно познакомился с очаровательной фотомоделью и сделал ей предложение.

4.Велосипедист и теннисист живут в одном доме, но видятся не чаще трёх раз в году.

5.Жена Алмаза по выходным любит готовить пельмени.

6.Жена шахматиста старше жены Рамиля на столько лет, сколько мячей забил футболист в последнем матче.

7.Мансур в этот раз не успел подписаться на газету «Вечерняя Казань».



Вы находитесь на странице вопроса "программа паскаль: выступают 3 спортсмена по прыжкам в высоту и нужно найти кто из них прыгнул выше,используя массив,числа в рандомном порядке выходят у", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.