Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста заполнить массив из 12 элементов случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива.

10-11 класс

саня4768 09 янв. 2014 г., 14:50:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bugaga27bkru
09 янв. 2014 г., 17:24:27 (10 лет назад)

#include <conio.h>
#include <iostream>
using namespace std;

int main()
{   
           int a[12],k;   
           cout<<"Massive before: ";   
           srand(time(NULL));   
           for(int i=0;i<12;i++)   
           {       
                    a[i]=(rand() % 25 -12);       
                    cout<<a[i]<<" ";       
                    if((i+1)%4==0) cout<<" | ";   
           }
           for(int j=0;j<3;j++)   
           {       
                      for(int i=0;i<2;i++)       
                      {           
                      k=a[j*4+i];           
                      a[j*4+i]=a[3+j*4-i];           
                      a[3+j*4-i]=k;       
                      }   
           }     
          cout<<endl<<"Massive       : ";   
          for(int i=0;i<12;i++)   
          {       
                       cout<<a[i]<<" ";       
                       if((i+1)%4==0) cout<<" | ";   
           }       
           getch();   
           return 0;


Ответить

Другие вопросы из категории

Помогите пожалуйста с задачками))) Pascal

1) Найти сумму всех элементов массива, заполненных случайными числами?
2) Найти сумму четных элементов массива?
3) Найти сумму элементов массива, стоящих на четных местах?

Олимпиадные задачи требуют ввод-вывод данных с использованием внешних файлов как это сделать? ИНФОРМАТИКА конспекты уроков 9-11 классы Чернов

А.А. с198

program pr;

uses crt;

var f:file of integer;

n:integer;

a:string;

begin

clrscr;

a:='c:\f1.txt';

assign(f,a);

rewrite(f);

writeln('n: ');

readln(n);

write(f,n);

close (f);

readln;

end.

после выполнения программы в файле f1.txt вместо значения n=5 появилось -256

что не так ?

«Крестики-нолики на полоске». Игровое поле в этой игре — полоска, разделённая на N клеточек. Играют двое. Первый игрок каждым своим ходом ставит

крестики в две любые свободные клетки, второй ставит в любую свободную клетку нолик. Цель первого игрока — поставить пять крестиков подряд. Второй же должен ему в этом помешать. Кто — начинающий или его соперник — победит в этой игре, как бы ни играл его партнёр? Рассмотрите случаи: а) N=10 Надо написать алгоритм действий для решения этой задачи. Помогите пожалуйста!

Читайте также

Помогите, пожалуйста!

заполнить массив из 9 элементов случайными числами в интервале в интервале [10,150] и найти min элемент массива, у которых вторая с конца цифра- нечетная

Срочно! Помогите! Написать программу в турбо паскале Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить,

есть ли в нем одинаковые соседние элементы.

Пример:

Исходный массив:

4 0 1 2 0 1 3 1 1 0

Заранее огромное спасибо!!!!

Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре. Пример: Исходный

массив:

14 25 13 30 76 58 32 11 41 97

Результат:

30 11 41 32 13 14 25 76 97 58

говорили про какой-то метод пузырька. хелп ми Т_т

p.s. паскаль abc

ребят ,если честно - срочно...

Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и найти в нем два максимальных элемента и их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0 максимальные a[4]=10, a[7]=8



Вы находитесь на странице вопроса "Помогите пожалуйста заполнить массив из 12 элементов случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.