Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Задание: составить программу решения задачи.

10-11 класс

Указания к выполнению: самостоятельно выполнить все этапы решения
задачи. Ввод и вывод матрицы оформить в виде процедур. При
необходимости выделить в задаче вспомогательные алгоритмы и оформить
их в виде подпрограмм.паскаль

Дана матрица, определить количество «особых» элементов. Элемент
считается «особым», если он больше суммы остальных элементов строки.
.

Alinkavyslova08 15 мая 2014 г., 22:45:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zinaida2554
16 мая 2014 г., 0:32:51 (9 лет назад)

const
  n = 10;
  m = 10;

type
  Matrix = array[1..n, 1..m] of integer;

procedure EnterMas(var Mas: Matrix);
var  i, j: integer;
begin
  randomize;
  for i := 1 to n do
    for j := 1 to m do
      Mas[i, j] := random(100);
end;

procedure GiveMas(var Mas: Matrix);
var  i, j: integer;
begin
  for i := 1 to n do
  begin
    for j := 1 to m do
    begin
      write(Mas[i, j], ' ');
    end;
    writeln;
  end;
end;

function SumStroki(Mas: Matrix; i, k: integer): integer;
var
  j, sum: integer;
begin
  sum := 0;
  for j := 1 to m do
    Sum := Sum + Mas[i, j];
  SumStroki := sum - k;
end;

function Element(var Mas: Matrix): integer;
var
  i, j, count: integer;
begin
  count := 0;
  for i := 1 to n do
    for j := 1 to m do
      if Mas[i, j] > SumStroki(Mas, i, Mas[i, j]) then inc(count);
  Element := count;
end;

var  Mas: Matrix;
  Sum, Max: integer;

begin
  EnterMas(Mas);
  GiveMas(Mas);
  writeln('Кол-во особых элементов ', Element(Mas));
end.

Ответить

Другие вопросы из категории

Помоги составить блок-схему. program h7; const n=15; p=3.14; var x: array [0..n] of integer; y: array [0..n] of real

;

i,h,k:integer;

a,s,max,min,t:real;

f:text;

begin

randomize;

k:=0;

s:=0;

for i:=0 to n do

begin

x[i]:=trunc(15*random);

end;

for i:= 0 to n do

write(x[i]);

for i:=0 to n do

if (x[i]<1) then y[i]:=0.5*(2+sqr(sin(x[i]-p/4)))+exp(x[i]) else

if(x[i]>=1) and (x[i]<=10) then y[i]:=4*exp(0.62*ln(x[i]))-2*sqrt(2*x[i])+1 else

if (x[i]>10) then y[i]:=5*exp(-x[i])+2*sqr(ln(x[i]));

for i:= 0 to n do

write (y[i]:5:1);

for i:= 0 to n do

s:=s+y[i];

a:=s/i;

max:=y[0];

min:=y[0];

for i:= 0 to n do;

if y[i]/0.3>a then

begin

if y[i]>max then begin

max:=y[i];

h:=i;

end

else

if y[i]<min then begin

min:=y[i];

k:=i;

end;

end;

t:=y[h];

y[h]:=y[k];

y[k]:=t;

for i:= 0 to n do

write (y[i]:5:1);

writeln ('----------------------');

assign (f,'f.txt');

rewrite(f);

end.

В некоторой местности соединение с сетью Интернет возможно только через спутник. При этом максимальная длительность однократного непрерывного сеанса

связи (время "видимости" спутника) не превышает 8 минут. Повторно спутник становится видимым только через 1 час 12 минут. Какой наибольший объем информации можно в этом случае передать через Интернет в течение суток, если скорость передачи информации составляет 100 Мбит в секунду? Считать, что передача информации начинается сразу с того момента, как спктник становится "видимым".

Хотя бы одно помогите сделать

Читайте также

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Помогите пожалуйста! Составить блок-схему алгоритма решения задачи, условие которой выбирается из списка в соответствии с номером варианта. Оплата за

пользование электроэнергией производится по разным тарифам в зависимости от того, установлены ли в доме электрические или газовые плиты. В первом случае (электрические плиты) стоимость 1 кВт/час составляет 2 руб., во втором – 2.5 руб. Составить программу расчета суммы оплаты за пользование электроэнергией за месяц, если известен расход электроэнергии (количество потребленных в течение месяца кВт/час)



Вы находитесь на странице вопроса "Задание: составить программу решения задачи.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.