Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я

10-11 класс

понял как
Console.WriteLine("Введите четырёхзначное число");
m = int.Parse(Console.ReadLine());
a = m / 1000; //последняя 1 цифра
b = m % 10;
допусти я ввёл число 6432 то прога выводит мне 6 и 2 мне надо ещё как то отдельно вывести цифры 4 и 3 и задать им отдельные переменные что бы сравнить

Викусякуся 21 сент. 2013 г., 6:15:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natka36
21 сент. 2013 г., 7:12:13 (10 лет назад)

Вариант 1. Из заданного числа вычесть количество тысяц, которые ты уже нашел. И по аналогии вычислить первую цифру получившегося трехзначного числа.
Вариант 2. Изначально распарсить все твое число в массив. И обращаться по индексу myNumber[1] вернет 4.

Ответить

Другие вопросы из категории

Помогите пожалуйста, очень нужно!!

Как сделать так, чтобы в презентации(PowerPoint) нарисованная качеля качалась бесконечно?

Укажіть правильне закінчення твердження: «Порожня таблиця СУБД MS Access, тобто таблиця, в якій немає жодного запису...».

А не містить жодних даних

Б містить дані про структуру бази даних

В містить дані про майбутні записи ; містить формули для обчислення значень полів

Г існувати не може

Читайте также

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Задача 7. Найти первый и последний элементы массива, кратные

числу 3.
Пример: массив 7 2 6 5 4 4 10 3 9
элементы, кратные 3 6 39
первый и последний из них 6 9

У исполнителя Аккорд две команды, которым присвоены номера:1. отними 12. умножь на x(x – неизвестное положительное число)Выполняя первую из них, Аккорд

отнимает от числа на экране 1, авыполняя вторую, умножает это число на x.Программа для исполнителя Аккорд – это последовательность номеровкоманд.Известно, что программа 12121 переводит число 6 в число 119.Определите значение x.

1)Дано : a=F716 , b= 3718 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?

А) 111110012 Б) 110110002 В) 111101112 Г) 111110002
2)Дано : a= DD16 , b = 3378 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110110102 Б) 111111102 В) 110111102 Г) 110111112
3)Дано : a=EA16 , b = 3548 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111010102 Б) 111011102 В) 111010112 Г) 111011002
4)Дано : a=3228 , b =D416 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110100112 Б) 110011102 В) 110010102 Г) 110011002
5)Дано : a= D116 , b= 3338 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111000112 Б) 110110102 В) 101011012 Г) 110111012
ПОМОГИТЕ ПОЖАЛУЙСТА!



Вы находитесь на странице вопроса "нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.