Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Тема: ABC Pascal. Простые и составные условия. Алгорическая конструкция (if, then, else и проч.)

10-11 класс

Задача 1

Xaliullinnail 29 сент. 2014 г., 16:31:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Belka5746
29 сент. 2014 г., 18:04:39 (9 лет назад)

1)
program chik;
var a,b:integer;
begin
read(a,b,c);
if(a mod b=0)then writeln('делиться')else writeln('не делиться');
end.
2)
program chik2;
var a:integer;
begin
read(a);
if(a mod 2=0)then writeln('да')else writeln('NO');
end.
3)
program chik3;
var a,b,c,max:integer;
begin
read(a,b,c);
max:=a;
if(b>max)then max:=b;
if(c>max)then max:=c;
writeln(max);
end.

+ 0 -
Dimka0203
29 сент. 2014 г., 19:17:09 (9 лет назад)

2)if a mod 2=0

+ 0 -
Darya200124
29 сент. 2014 г., 20:43:47 (9 лет назад)

3)max:=a;

+ 0 -
Marussia37
29 сент. 2014 г., 23:06:26 (9 лет назад)

if a<b then
max:=b;
if max<c then
max:=c;
writeln(max);

+ 0 -
кн67637
30 сент. 2014 г., 0:01:43 (9 лет назад)

все

+ 0 -
Komleva2002
30 сент. 2014 г., 1:26:32 (9 лет назад)

ставь лойсы

Ответить

Читайте также

Pascal ABC Операторы case of ; if then else ; for to do;

Помогите написать программы..........................................................................................
................................................. которые находятся в файле

Помогите пожалуйста написать программу на ABC Pascal.

Определить долю гласных букв в заданном тексте на английском языке.

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.



Вы находитесь на странице вопроса "Тема: ABC Pascal. Простые и составные условия. Алгорическая конструкция (if, then, else и проч.)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.