Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана длина окружности требуется вычислить радиус и площадь. в C#

10-11 класс

HeyHeyy 02 нояб. 2014 г., 6:43:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Grachevada99
02 нояб. 2014 г., 9:38:35 (9 лет назад)

using System;
using System.Collections.Generic;
using System.Linq;using System.Text;
namespace test
{    class Program
    {
        static void Main(string[] args)
        {           
            double P = double.Parse(Console.ReadLine());
            // Длина окружности равна P = 2ПR. Решаем по формуле:
            double R = P / 3.14 / 2;
            // Площадь окружности равна S = ПR*R
            double S = R * R * 3.14;
            Console.WriteLine("{0} - радиус, {1} - площадь", R, S);
        }
    }
}

вроде вот так

Ответить

Читайте также

Задачи в Paskal ABC

1.Дан радиус окружности. Вычислить длину окружности и площадь круга, ограниченного этой окружностью.
2.Даны 2 положительных числа. Вычислить их среднее арифметическое и среднее геометрическое.

Напишите программу. (в Паскале)

Дан радиус (R) окружности. Найти длину окружности (С) и площадь круга (S). С=2 ПR. S=ПR^2



Вы находитесь на странице вопроса "Дана длина окружности требуется вычислить радиус и площадь. в C#", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.