Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

10-11 класс

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Юлька33 25 марта 2015 г., 13:44:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ahmatgaleev
25 марта 2015 г., 15:24:09 (9 лет назад)

Var k, j, sum:integer;
n,i:longint;
prev,cur, found :boolean;
s:string;
Begin
  read(n,k);
 
  for i := 2 to n do begin
    s := inttostr(i);
    sum := 0;
    for j := 1 to length(s) do
      sum := sum + strtoint(s[j]);
    cur := (sum mod k) = 0;

    found := found or (prev and cur);
    if prev and cur then
      writeln(i - 1,' ',i);
     
    prev := cur;
  end;
  if not found then writeln('NO');
End.

Ответить

Читайте также

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

По краю очень большого круглого стола с равными интервалами разложены небольшие конверты, в каждом из которых лежат деньги. Известны суммы, лежащие в

каждом конверте. Опишите алгоритм, позволяющий провести прямую через центр стола, разделяющую конверты на два множества с одинаковой суммой денег. Прямая не должна проходить по конвертам. Если такой прямой нет – сообщите об этом.



Вы находитесь на странице вопроса "Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.