Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. Измените что надо сайт не пропускает. var

5-9 класс

i,n,t,k:Inteer;
begin
write('n:=');readln(n);
for i:=1 to n do begin
write(i,'-> ');readln(t);
if t=0 then inc(k);
end;
writeln(k);
end.

КузькаИруська 14 июня 2014 г., 12:49:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rozaccc
14 июня 2014 г., 14:18:56 (9 лет назад)

Ловите, сам написал, сам проверил, все работает.
var input, num, nulls, i: integer;
begin
write('Введите кол-во чисел: ');
readln(input);
for i := 1 to input do begin
  write('Введите число номером ', i, ': ');
  readln(num);
  if num = 0 then inc(nulls, 1);
end;
writeln('Кол-во нулей: ', nulls);
end.    

Ответить

Другие вопросы из категории

Очень срочно!!!!! Определить сколько книг поместиться на лазерном диске объем 700 Мбайт, если известно, что книга

состоит из 150 страниц, на каждой странице 40 строк в каждой строке по 60 символов?(Один символ имеет информационный объем 1 байт) Только всё надо разъяснить!!!!

Для данного x вычислить значение функции

корень из 5x+3, если x>=13
F(x)= 4x+3\x-5x^2, если x<-13

-

ответьте на вопросы :

Из каких источников вы получаете
информацию?

Ребят,помогите пожалуйста,щедро вознагражу баллами.Очень нужна ваша помощь,нужно сделать сегодня.Таблица перелетов из Москвы в разные города.

Вопросы: 1. В какое количество городов можно долететь менее чем за 4 часа? Ответ записать в ячейку H2 таблицы. 2. Какой процент от всех 5-часовых перелетов составляют 5-часовые перелеты в Египет? Ответ на этот вопрос нужно записать в ячейку H3 таблицы с точностью одного знака после запятой

Читайте также

Помогите очень срочно! 315. По данному натуральному n вычислите сумму 1^2 + 2^2+...+n^2. Вводится единственное число n. Необходимо вывести вычисленную

сумму. 346.Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел. 347.Вводится число N, а затем N чисел. Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

С клавиатуры вводятся 3 числа, подсчитать сколько среди них четных положительных чисел.

PS: использовать функцию деления по модулю:
a mod b- выдает остаток при делении числа а на число b
15 mod 2=1
15 mod 3=0

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему



Вы находитесь на странице вопроса "Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. Измените что надо сайт не пропускает. var", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.