Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найти сумму четных и произведение не четных чисел в промежутке от 1 до n

5-9 класс

Slavasvetikov 29 авг. 2013 г., 15:11:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Safonovamlat
29 авг. 2013 г., 16:11:55 (10 лет назад)

var  i, n,s,p: integer;
begin
write('Введите число: ');
readln(n);
p:=1;
for i := 1 to n do
    if i mod 2=0 then s:=s+i
      else p:=p*i;
writeln('Сумма четных: ',s,'; произведение нечетных: ',p)
end.

Ответить

Другие вопросы из категории

Читайте также

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

написать программу(на ABC pascal), которая находит сумму четных цифр

и произведение нечетных чисел
в диапазоне от 1 до 10.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "найти сумму четных и произведение не четных чисел в промежутке от 1 до n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.