Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Числа Фибоначчи определяются следующими формулами: f0=f1=1;

10-11 класс

fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать

Pasha1990 22 янв. 2014 г., 1:07:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jamesa008
22 янв. 2014 г., 3:53:47 (10 лет назад)

program gt;
var n,f1,f2,i,f:integer;
begin
readln(n);
f1:=1;f2:=1;
for i:=2 to n do
begin
f:=f1+f2;
f1:=f2;
f2:=f;
end;
writeln(f2);
end.

Ответить

Другие вопросы из категории

Ребятушки помогите срочно! Таблица в екселе...

Банк выдал ссуду 200 тыс. руб. на четыре года по 18% годовых. Определить размер ссуды, погашаемой ежегодно.

при регистрации в компьютерной системе каждому пользователю выдается пароль состоящий из 15 символов и содержащий только символы Е,Г,Э,2,0,1,3 и

кодируется минимальным кол-вом битов. определите обьем памяти,отводимый этой программе для записи 30 паролей

Сколько единиц в двочной записи чисел

1)1
2)11
3)3
4)33

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

Сумма

M первых чисел,
которые образуют последовательность Фибоначчи по следующему правилу: F1 =
1, F2 = 1, Fn+1 = Fn+Fn-1
для n>1 равна 102334154. Найдите число M

Ребят, спасайте, надо задачку решить на C#. Дано число D (> 0). Последовательность чисел AN определяется следующим образом:

A1 = 1, A2 = 2, AN = (AN–2+ AN–1)/2, N = 3, 4, ... Найти первый из номеров K, для которых выполняется условие |AK AK–1| < D, и вывести этот номер, а также числа AK–1 и AK.

Если не трудно, то пожалуйста с комментариями/обьяснениями!

Числа Фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765,

…, в которой каждое последующее число равно сумме двух предыдущих чисел. Количество простых чисел среди первых сорока пяти чисел Фибоначчи составляет …



Вы находитесь на странице вопроса "Числа Фибоначчи определяются следующими формулами: f0=f1=1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.