Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Нужно подробное написание программы в pascalABC

5-9 класс

1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
2) Написать программу, которая определяет, какая из двух точек расположена ближе к началу координат. Координаты вводятся с экрана.

Vnrgt 29 апр. 2014 г., 20:57:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
27894
29 апр. 2014 г., 23:13:52 (9 лет назад)

program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.

Ответить

Читайте также

Pascal ABC

Нужно подробное написание программы
-Распечатать таблицу перевода от 1 до 10 верст в метры (1 верста = 1067 м)

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Здравствуйте, мне нужна помощь с программой Excel.

Есть программа, которая преобразует слово из трех букв в число в 32-ичной сс(русс. алф).
После этого, переводит число в 10-ую сс.
Максимум может получиться 6 цифр, минимум 3.
Мне
нужно как-то сделать так, чтобы если у меня три цифры, то добавлялось
спереди три нуля, четыре цифры-добавлялось два нуля, пять
цифр-добавлялся один ноль, шесть-не добавлялось ни одного нуля.

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.



Вы находитесь на странице вопроса "Нужно подробное написание программы в pascalABC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.