Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Составить программу, которая будет вычислять сумму чисел, введенных с терминала,до тех пор, пока сумма не станет больше 30.

10-11 класс

Bolyspekov 11 апр. 2016 г., 11:38:31 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Index12
11 апр. 2016 г., 12:22:27 (7 лет назад)

var sum, x: integer;
begin
read (x);
sum:= x;
writeln (x);
while sum<=30 do begin
read (x);
sum :=sum+x;
writeln (x);
end;
end.

+ 0 -
20Deniska01
11 апр. 2016 г., 13:43:51 (7 лет назад)

язык паскаль?

Ответить

Другие вопросы из категории

Построение графика функции в

электронных таблицах у=х2+5 , при значении аргумента изменяющегося
от [-5;5], с шагом 1

Читайте также

Прошу мне очень срочно надо до пониделника.Я вас очен прошу помогите меня заране спосибо.

7)Задан алгоритм:некоторое число заменяется удвоенной суммой его цифр до тех пор,пока число не станет однозначным.Сопоставьте исходное значение числа с результатом исполнения алгоритма.

Исходное Значение Итоговый результат
1)87 А)8
2)473 В)5
3)1945 С)2
4)1231 D)4
5)5 E)6

8)Исполнитель Вычислитель может хранить в своей памяти только одно число и выполнять только три команды,которым присвоены номера:
0.число * 2
1.к числу + 1
2.обнулить результат
Программа для

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Составить программу, которая будет вычислять сумму чисел, введенных с терминала,до тех пор, пока сумма не станет больше 30.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.