Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Известны баллы, полученные студентами за контрольную работу. Вычислить максимальный балл.

10-11 класс

Нужно написать программу а паскале, помогите пожалуйста)

GvDUGBD 20 окт. 2014 г., 21:28:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
попец23
20 окт. 2014 г., 23:30:31 (9 лет назад)

var
  n, p: integer;
  s: real;

begin
  p := -1;
  n := 0;
  writeln('Вводите отметки, конец ввода по числу 0');
  repeat
    readln(p);
    if p > 0 then begin
      s := s + p;
      n := n + 1
    end
  until p = 0;
  writeln('Средний балл', s / n:5, 3)
end.

Ответить

Другие вопросы из категории

СРОООООЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Читайте также

1) Сколько следует задать вопросов и как их следует формулировать, чтобы количественно оценить сообщение о том, что вагон стоит на одном из 16 путей?

2) Вы бросаете два кубика с нанесенными на гранях цифрами от 1 до 6. Определите, сколько битов информации несет сообщение о том, что на одном кубике выпала тройка, а на другом- пятерка.
3) Предположим, вероятность того, что вы получите за контрольную работу оценку "5", равна 0,6; вероятность получения "4" равна 0,3; вероятность получения "3"-0,1. Определите, сколько битов информации будет нести сообщение о результатах контрольной работы в каждом из вариантов. ПОЖАЛУЙСТА, ПОМОГИТЕ!!!

Ваня работал в каталоге С:\Пользователи\Громов Иван\Контрольные работы\Информатика

Когда он выполнил задание, он решил сделать самопроверку,зайдя в папку с ответами. Для этого он поднялся на три уровня вверх и спустился на два уровня вниз. куда в итоге попал Ваня?
А) С:\Пользователи\Громов Иван
В) С:\Пользователи\Учитель
С)С:\Пользователи\Учитель\Ответы
D)С:\Пользователи\Громов Иван\Контрольные работы\Ответы

Упорядочите события по возрастанию количества информации, содержащегося в сообщении об их результате. 1) бросание игрального куба 2) пуск

рулетки

3) отметка, полученная за контрольную работу

4) подбрасывание монеты

а)за контрольную работу учитель поставил 4 пятерки.Сообщение,что вы получили за контрольную пять,содержит 2 бит информации.Определите,сколько человек

всего в классе?

б)Известно,что сообщение учителя о том что к доске пойдет Саша Орлов,содержит 5 битов информации. Сколько учеников в классе?

Ваня работал в каталоге С:\Пользователи\Громов Иван \ Контрольные работы \ Информатика.

Когда он выполнил задание, он решил сделать самопроверку, для этого он поднялся на три уровня вверх и спустился на два уровня вниз. Куда в итоге попал Ваня?
A) C: \Пользователи \ Громов Иван
B) C: \Пользователи Учитель
C) C: \Пользователи \ Учитель \Ответы
D) C: \Пользователи \ Громов Иван \Контрольные работы \Ответы



Вы находитесь на странице вопроса "Известны баллы, полученные студентами за контрольную работу. Вычислить максимальный балл.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.