Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу, которая бы находила сумму нечётных элементов одномерного целочисленного массива. Способ заполнения массива - любой (или при

5-9 класс

помощи функции random или при помощи простого присваивания).

Smile09 27 окт. 2016 г., 5:29:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elinka65
27 окт. 2016 г., 7:41:34 (7 лет назад)

var

  a:array[1..100] of integer;

  Summ, i, n:integer;

begin

  write('Введите количество элементов массива ');

  readln(n);

  for i := 1 to n do

  begin

    a[i] := random(51) - 25;

    write(a[i], ' ');

    if a[i] mod 2 <> 0 then

      Summ := Summ + a[i];

  end;

  writeln;

  writeln('Summ = ', Summ);

end.

Ответить

Другие вопросы из категории

3.Чем отличается информация от сообщения? Приведите примеры. 4.Что такое кодирование, декодирование? Приведите примеры. 5.В чём смысл

кол-ва информации? Какова связь кол-ва инф-ии с энтропией, хаосом?

6.Что означает термин «актуализация информации»?

7.Каковы основные свойства инф-ии?

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.



Вы находитесь на странице вопроса "составить программу, которая бы находила сумму нечётных элементов одномерного целочисленного массива. Способ заполнения массива - любой (или при", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.