Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

как решать? может кто нить объяснить? пожалуйста

10-11 класс

ааааав 29 нояб. 2016 г., 3:47:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexkopitov1973
29 нояб. 2016 г., 4:35:34 (7 лет назад)

1.18 a 57 b -31.2 c -15 d 20
1.19 a -10 b -35 c 0 d -75
1.20 a k=30 s=15  b k=50 s=-50


+ 0 -
Denshik5563
29 нояб. 2016 г., 6:30:03 (7 лет назад)

               Операция:               Результат {Вывод(s)}
a)               s:=5                               s = 5  (5)
               s:=57                              s = 57   (57)
б)               s:=6                              s = 6    (6)
               s:=-5.2*s                              s = -31.2 (-31.2)
               s:= 0                              s = 0    (0)
в)               s:= -7.5                               s = -7.5  (-7.5)
               s:= 2* s                              s = -15   (-15)
г)               s:=45                              s = 45    (45)
               s:= -25                              s = -25 (-25)
               s:= s + k,  в большинстве случаев переменной к будет присвоено значение по умолчанию = 0. при неопределённом значении к компилятор не создаст программу или, эта операция вызовет ошибку при попытке ее выполнения, если обработать операцию в исключительной ситуации  типа {try ... except}  то после выполнения вывода значения s увидим что результат не изменился, так как операция не была выполнена (если язык программирования не выполняет никаких проверок то возможен случайный результат) s = -25    (-25)

если надо результат выводить в программе, то после каждого присваивания надо писать процедуру вывода. Например WriteLn(s) - для Паскаль

1.20)
а)               s:=14                              s = 14, k = , d =     (14)
               k:= -3                              s = 14,  k = -3, d =   (14, -3)
               d:= s +1                           s = 14,  k = -3, d = 15  (14, -3, 15)
             s:= d                           s = 15,  k = -3, d = 15  (15, -3, 15)
             k:= 2 * s                           s = 15,  k = 30, d = 15  (15, 30, 15)
думаю смысл ясен, остальное аналогично...

Ответить

Другие вопросы из категории

Дан одномерный массив целых чисел.. Колличество чисел и их значения вводятся с клавиатуры . Индексация элементов массива начинается с единицы.

Определить произведение элементов массива, которые являются отрицательными четными числами. Если аких чисел нет, то вывести на экран нуль

Дано натуральное число n. Определить сумму цифр во второй половине числа и сумму цифр в первой половине числа n.

(Пояснение к занятию: при решении задач целочисленной арифметики используются операторы цикла, операции mod и div.)

Помогите пожалуйста с программированием!!!

1) не надо
2)нужен только ответ
3)нужен только ответ
4)нужен только ответ
5) составить программу
6)составить программу
Помогите очень прошу!!!

написать в паскале используя циклы:

Среди всех натуральных трехзначных чисел найти и вывести на экран только кратные пяти и вычислить их количество.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100. Опишите на русском языке или на одном из языков

программирования алгоритм , позволяющий найти и вывести произведение двузначных элементов массива, которые не делятся на 6.Гарантируется, что в исходном массиве есть хотя бы один такой элемент. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них. Исходные данные всегда подобраны так, что результат произведения не выходит за пределы объявленных типов данных.

Паскаль:
const N=30
var a : array [1..N] of longint;
i, j, p:longint;
begin
for i := 1 to N do
readln(a[i]) ;
...
end.

Читайте также

Для групповых операций с файлами используются маски имен файлов.

Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которых также могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность.
Определите, какое из указанных имен файлов не удовлетворяет маске: sys?.*
1) syste.m
2) sys23.exe
3) system.dll
4) syszx.problem
Как это решать, объясните пожалуйста.

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

Объем сообщения составил 32 Кбайта. На одной странице помещается 16 строк по 64символа в каждой. Число страниц, которое занимает сообщение, равно 64.

Алфавит, спомощью которого записано сообщение, содержит _____ символов.

объясните пожалуйста как решается

В столовой предлагается N комплексных обедов,состоящих из Q блюд.

Известны стоимость и калорийность каждого блюда. Сколько стоят самый
дешевый и самый дорогой обеды? Сколько калорий включает в себя самое
калорийное блюдо? Кто нибудь знает как решить? скиньте пожалуйста файлом, задача решается в XL.



Вы находитесь на странице вопроса "как решать? может кто нить объяснить? пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.