Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

N¤~¤Factorial- это произведение всех чиселот 1 доN . Для заданного числа N определите , сколько нулей в конце десятичной записи N ¤-¤Factorial. pomagite

5-9 класс

pojaluistA

Smelianskyniki 22 марта 2017 г., 16:14:02 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Никуся123456
22 марта 2017 г., 17:27:28 (7 лет назад)

Только с олимпиады, много лишнего(наверно) но как есть.
uses crt;
var a,s,f,i:integer;
    f1,s1:string;
    r,g:text;
begin
assign (r,'C:\Ain.txt');
reset (r);
readln (r,a);
close (r);
f:=1;
for i:=2 to a do
f:=f*i;
str(f,f1);
for i:=1 to length(f1) do
begin
s1:=copy(f1,1,1);
if s1<>'0' then
delete(f1,1,1);
end;
for i:=1 to length(f1) do
begin
s1:=copy(f1,1,1);
if s1='0' then
s:=s+1;
end;
assign (g,'C:\Aout.txt');
rewrite (g);
writeln (g,s);
close(g);
end.

Ответить

Другие вопросы из категории

Страница книги содержит примерно 5000 символов.Сколько приблизительно 200- страничных книг можно записать на оптический диск емкостью 650 Мбайт? для

кодирования одного символа используеться 8 битов.помогите очень срочно надо.пожалуйста.

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "N¤~¤Factorial- это произведение всех чиселот 1 доN . Для заданного числа N определите , сколько нулей в конце десятичной записи N ¤-¤Factorial. pomagite", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.