Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создать програму на Paskal. Відомості про книгу складаються з прізвища автора, назви та року видання. Ввести набір з 12 таких

10-11 класс

відомостей. Знайти назву книг даного автора, виданих з 1970 по 1990 рік. Впорядкувати відомості по першій літері прізвища автора. Замінити старий рік видання на 1992р., передбачаючи, що одна з книг перевидана.

Dasha1359565 10 июня 2013 г., 15:42:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maksimlavrov171
10 июня 2013 г., 18:41:40 (10 лет назад)

Я плохо понимаю украинский, я сделал сортировку массивов по фамилиям автора от а до я. и заменил даты меньшие 1970. 

uses crt;
var
a,b,i,j,y1,buk:integer;
g: array [1..12] of integer;
f: array [1..12] of string;
n: array [1..12] of string;
y:string;
begin
clrscr;
for i:=1 to 3 do begin
write('vvedite nazvanie= ');
readln(n[i]);
write('vvedite famoliu= ');
readln(f[i]);
write('vvedite god izdania= ');
readln(g[i]);
end;

for i:=2 to 3 do begin
buk:=i-1;
for j:=i to 3 do begin
if f[j][1]<f[buk][1] then
buk:=j;
end;
y:=f[i-1];
f[i-1]:=f[buk];
f[buk]:=y;

y:=n[i-1];
n[i-1]:=n[buk];
n[buk]:=y;

y1:=g[i-1];
g[i-1]:=g[buk];
g[buk]:=y1;
if g[i-1]<1970 then
g[i-1]:=1992;
end;
if g[12]<1970 then
g[12]:=1992;
for i:=1 to 3 do
writeln(n[i], ' ',f[i], ' ',g[i]);
end.

Ответить

Другие вопросы из категории

«Узник замка Иф»За многие годы заточения узник замка Иф проделал вилкой в стене прямоугольное отверстие размером d x e. Замок Иф сложен из кирпичей

размером a x b x c. Узник хочет узнать, сможет ли он выбрасывать кирпичи в море из этого отверстия, чтобы сделать подкоп. Снабдите его необходимым для решения задачи софтом. На вход программе подаются 5 чисел (a, b, c, d, e), программа должна давать ответ YES или NO.

Помогите ответить на вопросы!!

1. Виды и свойства информации.
2. Моделирование.

Заранее спасибо)

Читайте также

Ети задания нужно реализовать на Paskal 1. Побудувати на екрані прямокутну систему координат, позначити початок і осі

координат. Побудувати два зафарбованих трикутники, симетричних відносно початку координат. Вершини трикутників з'єднати пунктирними лініями.

2. Зобразити сонце із променями, довжини яких вибираються випадковим чином з інтервалу (20, 80).

3. Побудувати графік функції крапками, вибравши розташування координатних осей на екрані й масштаб: y= (х2 -4х+3)2 ;

4. Побудувати криві по їхніх рівняннях, заданим у полярних координатах:

ρ= a/φ (а> 0);

5. Побудуйте стовпчасту діаграму, що відображає результати останньої сесії в кожній із груп. Дані про середню оцінку в кожній групі зберігаються в масиві О[ 1...10] .

Помогите нужен линейный алгоритм на паскале. Составить алгоритм для решения задачи: Книга стоит d

руб., журнал h руб. У покупателя денег S руб. Хватит ли их на 3 журнала и 2
книги?.

) Задан двухмерный

массив. Найти сумму элементов первой и третьей строк матрицы.создать программу на этот алгоритм через abc paskal,

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите создать программу на паскаль:

Разработать
программу в соответствии со своим вариантом: создать структуру типа «запись», выполнить
обработку данных.



Вы находитесь на странице вопроса "Создать програму на Paskal. Відомості про книгу складаються з прізвища автора, назви та року видання. Ввести набір з 12 таких", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.