Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Массивы в С++.

10-11 класс

Не работает пример из книжки.

дияяночка 23 авг. 2013 г., 7:24:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DeriviolcoW
23 авг. 2013 г., 9:39:32 (10 лет назад)

У Вас во втором цикле переменная не объявлена (заменить на int j) и в выделенной красной строке нет оператора, за cin таскающегося:
cin >> age[j]
P.S. Удачи в освоении:)
P.S.S. Рабочий пример ниже, на всякий случай

+ 0 -
Kenzhe
23 авг. 2013 г., 12:29:02 (10 лет назад)

// replay.cpp
#include <iostream>
using namespace std;
///////////////////////////////////////////////////////////
int main ( )
{
int age [ 4 ];
for ( int j = 0; j < 4; j++ )
{
cout << "Ввести возвраст:: ";
cin age [ j ];
}
for ( j = 0; j < 4; j++ )
cout << "Вот он: " << age [ j ] << endl;

system("pause");
return 0;
}

Ответить

Другие вопросы из категории

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Паскаль, составьте программу для двумерного массива:

Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

Составить программу для решения следующей задачи: Результаты соревнований по прыжкам в воду и порядковый номер участников хранятся в массиве. Нечетный

элемент массива определяет номер участника, четный — результат. Определите и выведите на экран лучший и худший результаты с номерами спортсменов.



Вы находитесь на странице вопроса "Массивы в С++.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.