Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Запись некоторого натурального числа Х в шестнадцатеричной системе счисления имеет ровно три значащих разряда. Это число увеличили в два раза, и оказалось,

5-9 класс

что запись получившегося числа У в шестнадцатеричной системе также имеет ровно три значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа Х равна сумме цифр шестнадцатеричной записи полученного числа У. Сколько существует таких чисел Х,
которые удовлетворяют указанным условиям и при этом содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе укажите целое число.


Сделайте пожалуйста на Паскале ABC

Yura777777karo31 15 февр. 2014 г., 8:55:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ik9omsk
15 февр. 2014 г., 9:55:30 (10 лет назад)

var
  n, k, d2, d1, d0: integer;
  e2, e1, e0: integer;

procedure GetDigits(m: integer; var d2, d1, d0: integer);
{Перевод числа [100..FFF]в 16-ю систему счисления}
begin
  d0 := m mod 16;
  m := m div 16;
  d1 := m mod 16;
  d2 := m div 16
end;

begin
  n := 0;
  {Рассматриваем шестнадцатиричные числа от 100 до 7FF}
  for k := $100 to $7FF do
  begin
    GetDigits(k, d2, d1, d0);
    if (d2 = 2) or (d1 = 2) or (d0 = 2) then
    begin
      GetDigits(2 * k, e2, e1, e0);
      if d0 + d1 + d2 = e0 + e1 + e2 then n := n + 1
    end
  end;
  writeln('n=', n)
end.

Тестовое решение:

n=23


Ответить

Читайте также

Запись некоторого натурального числа Х в шестнадцатеричной системе счисления имеет ровно два значащих разряда. Это число увеличили в два раза, и оказалось,

что запись получившегося числа У в шестнадцатеричной записи также имеет ровно два значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа Х равна сумме цифр шестнадцатеричной записи полученного числа У. Сколько существует таких чисел Х, которые удовлетворяют указанным условиям? В ответе укажите целое число.

Перевести число 36910 в двоичную, восьмеричную и шестнадцатеричные системы счисления

Перевести число 11100012 в восьмеричную, десятичную и шестнадцатеричные системы счисления

Сколько единиц в двоичной записи числа 195? Сколько единиц в двоичной записи числа 173? Как представлено число 25 в двоичной системе счисления? Как

представлено число 82 в двоичной системе
счисления? Как представлено число 263 в восьмеричной
системе счисления?

Симметричным трехзначным числом будем считать число, запись которого имеет ровно три значащих цифры,и первая цифра совпадает с последней. Определите

минимальное основание системы счисления, в которой можно записать не менее 200 трехзначных чисел, не являющихся симметричными. В ответе укажите целое число.

Как представлено число 8310 в двоичной системе счисления?

Сколько единиц в двоичной записи числа 195?
Как представлено число 26310 в восьмеричной системе счисления?
Решите,пожалуйста,сколько сможете)



Вы находитесь на странице вопроса "Запись некоторого натурального числа Х в шестнадцатеричной системе счисления имеет ровно три значащих разряда. Это число увеличили в два раза, и оказалось,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.