Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

помогите срочно с информатикой: написать программу, которая в массиве размерностью в 10 на 12 находит сумму: 1)всех элементов массива.

10-11 класс

2) каждого столбца.
3) каждой строки.
10 класс... плизз...

Olgachernaya1 07 авг. 2014 г., 5:38:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Guzel1982
07 авг. 2014 г., 6:31:54 (9 лет назад)

const m=10; n=12;
var a:array [1..m,1..n] of integer;
i,j:integer;
sob:integer;
sst:array[1..n]of integer;
sstr:array[1..m]of integer;
begin
randomize;
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=random(10);
write(a[i,j]:3);
end;
writeln;
end;
sob:=0;
for i:=1 to m do begin
for j:=1 to n do begin
sob:=sob+a[i,j];
end;
end;
writeln('сумма всех элементов массива = ', sob);
writeln;
writeln;
for i:=1 to m do begin
sstr[i]:=0;
for j:=1 to n do begin
sstr[i]:=sstr[i]+a[i,j];
end;
end;
writeln('сумма элементов построчно');
for i:=1 to m do write(sstr[i]:3);
writeln;
writeln;
for j:=1 to n do begin
sst[j]:=0;
for i:=1 to m do begin
sst[j]:=sst[j]+a[i,j];
end;
end;
writeln('сумма элементов по столбцам');
for j:=1 to n do write(sst[j]:3);
end.

Ответить

Другие вопросы из категории

С ПОДРОБНЫМ РЕШЕНИЕМ!

Ирена любит мороженое с фруктами. В кафе был выбор из таких вариантов:

пломбир с орехами; пломбир с бананами; пломбир с черникой; шоколадное с черникой; шоколадное с клубникой.

В четырёх вариантах Ирене не нравились или тип мороженого, или наполнитель, а в одном варианте ей не нравились ни мороженое, ни наполнитель. Она попросила приготовить из имеющихся продуктов порцию по своему вкусу.

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "помогите срочно с информатикой: написать программу, которая в массиве размерностью в 10 на 12 находит сумму: 1)всех элементов массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.