Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Всем привет. Помогите, пожалуйста, разобраться с этой задачей. Как ее решить в Pascal.

10-11 класс

"Вычислить сумму элементов строки, проходящей через первый нулевой элемент побочной диагонали матрицы Q(30,30)."

Irishkaserikova 27 февр. 2015 г., 22:50:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zverina
28 февр. 2015 г., 1:49:42 (9 лет назад)

var a:array[1..30,1..30] of integer;
i,j,s:integer;
begin
for i:=1 to 30 do begin
  for j:=1 to 30 do begin
    a[i,j]:=random(-5,5);
    write(a[i,j]:3);
  end;
  writeln;
end;
for i:=1 to 30 do
  if a[i,31-i]=0 then break;
for j:=1 to 30 do
  s+=a[i,j];
writeln(s,' ',i);
end.

Ответить

Другие вопросы из категории

составить блок схему и программу
В исходной строке а$

определить и вывести слова, в которых первая буква встречается всего один раз.(Бэйсик)

составить программу в паскале.

Формат ввода:
вводится одно натуральное число N, не превосходящее 50.
Формат ввода:
Выведите 1,если данное число просто и 0, в противном случае.

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Доброго времени суток, помогите пожалуйста с решением данной задачи, необходим код, для Turbo Pascal. Сама задача звучит так:

С клавиатуры вводится 3 числа, если сумма первого и последнего больше 10, то вывести эту сумму, если произведение больше 20, но меньше 30 (20>>30) то вывести это произведение, в противном случае вывести все эти 3 числа.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Такое впечатление, что к этой задаче не предложили правильный ответ! Помогите, пожалуйста разобраться:

Эдуард написал макрос для текстового редактора, который реализует 4 действия: перейти к абзацу с заданным номером в текущем текстовом документе; вырезать содержимое выделенного абзаца и поместить его в буфер обмена; выделить текущий абзац; вставить содержимое буфера обмена перед текущим абзацем. Сколько действий из этого набора, необходимо выполнить, что бы поменять две группы по два абзаца местами?
А) 22 Б) 24 В) 26 Г) 28



Вы находитесь на странице вопроса "Всем привет. Помогите, пожалуйста, разобраться с этой задачей. Как ее решить в Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.