Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

написать программу Нахождение сумму и количество отрицательных чисел в массиве

1-4 класс

B {7}

Sofia300901 30 сент. 2013 г., 12:21:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tasyashovenko
30 сент. 2013 г., 14:17:00 (10 лет назад)

const
  n = 7;

var
  B: array[1..n] of integer;
  i, s, k: integer;

begin
  Randomize;
  s := 0; k := 0;
  Write('Элементы массива: ');
  for i := 1 to n do
  begin
    B[i] := Random(101) - 50;
    if B[i] < 0 then begin
      k := k + 1;
      s := s + b[i]
    end;
    Write(B[i]:5)
  end;
  Writeln(#13#10, 'В массиве ', k, ' отрицательных элементов; их сумма ', s)
end.

Тестовое решение:

Элементы массива:   -41   26   -3   -9  -18   -2   33
В массиве 5 отрицательных элементов; их сумма -73


Ответить

Читайте также

Известно количество

символов в каждой строке, количество строк на странице. Написать программу,
считывающую эти значения с клавиатуры и вычисляющую число символов на странице.



Вы находитесь на странице вопроса "написать программу Нахождение сумму и количество отрицательных чисел в массиве", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.