Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача: Написать программу вычисления суммы всех двузначных чисел

5-9 класс

S=10+11+12+...+99

для QBasic

5598 26 июля 2014 г., 16:53:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fhyt
26 июля 2014 г., 19:06:42 (9 лет назад)

program vsum;
var
a,b,x : integer;
const
error = 'Error! Enter two-digit number.';
begin
Write('Enter a =');
ReadLn(a);
if (a <= 99) and (a >= 10) then
begin
Write('Enter b =');
ReadLn(b);
if (b <= 99) and (b >= 10) then
begin
x := a+b;
WriteLn('a + b = ',x);
end
else
Write(error);
exit;
end
else
WriteLn(error);
exit;
end.

Ответить

Другие вопросы из категории

игорь получил алгоритм для нахождения кода числового замка "В последовательности цифр к каждой цифре строящей на нечетной позиции прибавить 1 и из каждой

цифры стоящей на четной позиции отнять 2. затем вычеркнуть каждую 3 цифру. какой код должен получиться если применить данный алгоритм к последовательности цифр 1567327

Укажите правильный вариант неполного ветвления

A. THEN<серия оператора 1> ELSE<серия оператора 2>;
B. IF<условие> ELSE<серия оператора 2> end ;
C. IF<условие> THEN<оператор>;
D. ELSE<серия оператора 2> IF<условие>:

нужна программа в цикле for или reped или while

население города на начало года составляло 0,62 мил

ПОМОГИИИТЕ.ДУМАЛА ТА ПОМОЖЕТ.НО НЕТ=(

11101111211100101211110000211101000211101110211100100210000021110111121111000021110000021110001021110101121110010121110110121110100021111111121000002110100002111011102111011002111000002111011012111011102111000102111110112111101012

Читайте также

ПОМОГИТЕ ОЧЕНЬ НАДО!

Дано целое число n, которое больше либо равно 0 и меньше либо равно 9.
Написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.

1. Производительность формовочной машины - 7 тарелок в минуту. Сколько тарелок произведут N машин за T часов?

2. Составить программу удвоения большего из двух чисел.

3. Написать программу вычисления произведения всех двузначных четных чисел.

4. Определить количество двузначных натуральных чисел, сумма цифр которых равна заданному числу N.

Все в Pascal. Очень прошу помочь

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

пожалуйста... срочно надо!!

НУЖНО с Basic !!!!
составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел , кратных 5!!

нужно с if



Вы находитесь на странице вопроса "Задача: Написать программу вычисления суммы всех двузначных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.