Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ С ПРОГРАММИРОВАНИЕМ!!! 11 КЛАСС!!

10-11 класс

описать данную программу словами! как в примере:

Начало t1
Приглашение для ввода строки
Ввод строки
Задать начальные значения переменных
Обработка строки
Вывод результата - какой д. б. результат?
Конец t1
Конец t1




Program ww;

var k,s:string;

i:integer;

begin

writeln ('Введите слово из четного числа букв');

readln (s);

k:= 'vv';

writeln ('обработка строки');

for i:=1 to round(length(s)/2) do

k:=k+s[i];

s[i]:=s[length(s)-i];

s[length(s)-i]:=k; }

writeln (k); {Вывод результата}

end.

Valeriasosnowa 24 июня 2015 г., 10:39:11 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikaantropova19
24 июня 2015 г., 13:13:02 (8 лет назад)

Начало ww
Приглашение для ввода строки
Ввод строки
Задать начальные значения переменных
Обработка строки 

+ 0 -
Bef
24 июня 2015 г., 14:35:45 (8 лет назад)

"какой д. б. результат?" - не понимаю, можно расшифровать?))

+ 0 -
Vitalii11
24 июня 2015 г., 15:47:06 (8 лет назад)

какой должен быть результат)

+ 0 -
8888899
24 июня 2015 г., 18:21:14 (8 лет назад)

программа немного изменилась. нужно писать к этой!!!!!!!!!!!!!!!!!!!!!!!!

Program ww;
var k,s:string;
i,l:integer;
begin
writeln ('Введите слово из четного числа букв);
readln (s);
k:= '';l:=round(length(s)/2) ;writeln (l);
writeln ('Обработка строки');
for i:=1 to l do
k:=k+s[i];
delete(s, 1, l ); writeln (s);
s:=s+k;
writeln (s); {Вывод результата}
end.

Ответить

Другие вопросы из категории

Предлагается некоторая операция над двумя произвольными трехзначными десятичными числами: Записывается результат сложения старших разрядов этих чисел.

К нему дописывается результат сложения средних разрядов по такому правилу: если он меньше первой суммы, то полученное число приписывается к первому слева, иначе – справа. Итоговое число получают приписыванием справа к числу, полученному после второго шага, сумму значений младших разрядов исходных чисел. Какое из перечисленных чисел могло быть построено по этому правилу? 1) 141310 2) 102113 3) 101421 4) 101413

Помогите!!!

Дана целая квадратная матрица, n- го порядка. Определить, является ли она магическим квадратом, т.е. такой, в которой сумма элементов во всех строках и столбцах одинаковая.

1)составить программу. определяющуя является ли веденное слово перевертышем. входные данные: ввести строку S с длинной не более 255 символов. выходные

данные: вывести количество содержащихся в ней прописных латинских букв.

2)дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими). найти количество слов, которые начинаются и заканчиваются одной и той же буквой.

выберите правильный вариант ответа: Какой из следующих типов диаграммы можно установить в табличном процессоре? а)

rong>круговая б)прямоугольная с)графиг д)областная е)линейная



Вы находитесь на странице вопроса "ПОМОГИТЕ С ПРОГРАММИРОВАНИЕМ!!! 11 КЛАСС!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.