Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Задача на языке Паскаля

5-9 класс

Abricos2001 03 февр. 2016 г., 7:05:22 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nohchieva01
03 февр. 2016 г., 8:22:00 (8 лет назад)

Сделать эту задачу можно двумя способами. Первый - чисто арифметический. Второй - более хитрый, через операции над строками. Мы пойдем вторым путем, он короче и практичней, такой код будет требовать меньше ресурсов машины для реализации (что незаметно в таких маленьких задачках, но довольно критично в реальной жизни, поэтому учимся писать дальновидные коды).

Var n:longint;

Function MinDigit(n:longint):integer;
var s,a:string; c,i:integer;
begin
 str(n,s);
 a:=s[1];
 for i:=2 to length(s) do
   if s[i]<a then a:=s[i];
 val(a,n,c);
 MinDigit:=n;
end;

Function MaxDigit(n:longint):integer;
var s,a:string; c,i:integer;
begin
 str(n,s);
 a:=s[1];
 for i:=2 to length(s) do
   if s[i]>a then a:=s[i];
 val(a,n,c);
 MaxDigit:=n;
end;

Begin
 readln(n);
 writeln(MinDigit(n),' ',MaxDigit(n));
End.

По факту переменную "c" можно убрать из функций и использовать вместо нее уже не нужную в конце "i", таким образом избавившись от одной переменной. Но это не принципиально на самом деле, к тому же так понятней, какая переменная за что отвечает.

Ответить

Другие вопросы из категории

Система уравнений в Excel

x+y=8
x^2+y^2=16+2xy
нужно решить эту систему уравнений в Excel

К реке подъехали 4 мушкитера и их слуги и обнаружили одну трехместную лодку . Как смогут ли они переправиться на другой берег при условии , что ,

оказавшись отдельно от своего мушкитера , ни один слуга не находился бы при этом в обществе других мушкитеров ? Мушкитеры тоже согласились грести .

программист Василий Кадров недавно получил банковскую карточку.Чтобы не забыть пароль к карточке, Василий решил построить его по алгоритму, а именно :

пароль равен количеству чисел от 1 до 10000, не делящихся на 13 и 17.Чему равен пароль Васи?

слова связынные с компьютером 4 буква т

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Задача на языке паскаль!

Определить принадлежит ли точка A(x) лежащая на координатной прямой отрезку [-3,3].



Вы находитесь на странице вопроса "Задача на языке Паскаля", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.