Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Сколько единиц в двоичной записи числа 173 ? помогите пожалуйста прошу, если тут что-то надо расписать - напишите подробно!

10-11 класс

Micky 16 июля 2015 г., 19:40:08 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shemis00
16 июля 2015 г., 20:53:01 (8 лет назад)

Другой способ перевода из десятичной системы в двоичную: берем число и делим его столбиком на основание системы, в которую переводим. Нацело. Если есть остаток, то его оставляем. А получившееся часное снова делим на основание требуемой системы. И так далее, пока часное не перестанет делится нацело. А чтобы записать число в требуемой системе, записываем последнее часное, а потом все остатки, начиная с последнего. (кстати, по аналогии можно переводить в любую другую систему).

 

173|   2

172   86|  2

   1   86   43|  2

          0   42   21|  2

                1   20   10|  2

                       1   10   5|  2

                             0    4   2|  2

                                   1   2   1

                                        0

 

173_{10} = 10101101_2

 

Итого: в записи 5 единиц.

+ 0 -
Kristisha13
16 июля 2015 г., 23:09:23 (8 лет назад)

Для начала переведем число в 2 с.с., представив, как сумму степеней основания(2).

173=128+32+8+4+1=2^7+2^5+2^3+2^2+2^0

Теперь запишим полученное число:

10101101_{2}

А теперь самое сложное - посчитать единицы! (5 единиц)

Ответить

Другие вопросы из категории

Помогите пожалуйста , я сейчас на уроке очень срочно!!!!

Составьте программу нахождения количество цифр натурального числа n.

ПОМОГИТЕ С ПРОГРАММИРОВАНИЕМ!!! 11 КЛАСС!!

описать данную программу словами! как в примере:

Начало t1
Приглашение для ввода строки
Ввод строки
Задать начальные значения переменных
Обработка строки
Вывод результата - какой д. б. результат?
Конец t1
Конец t1




Program ww;

var k,s:string;

i:integer;

begin

writeln ('Введите слово из четного числа букв');

readln (s);

k:= 'vv';

writeln ('обработка строки');

for i:=1 to round(length(s)/2) do

k:=k+s[i];

s[i]:=s[length(s)-i];

s[length(s)-i]:=k; }

writeln (k); {Вывод результата}

end.

Предлагается некоторая операция над двумя произвольными трехзначными десятичными числами: Записывается результат сложения старших разрядов этих чисел.

К нему дописывается результат сложения средних разрядов по такому правилу: если он меньше первой суммы, то полученное число приписывается к первому слева, иначе – справа. Итоговое число получают приписыванием справа к числу, полученному после второго шага, сумму значений младших разрядов исходных чисел. Какое из перечисленных чисел могло быть построено по этому правилу? 1) 141310 2) 102113 3) 101421 4) 101413

Читайте также

1.Переведите числа 25, 31, 37, 63, 85, 127, 128 в двоичную систему счисления.

2. Переведите числа 1000112, 1011012, 1101112, 10010112, 10111112, 11010012 в десятичнуюсистему счисления.
3. Сколько единиц в двоичной записи чисел 173, 195, 126, 208?
4. Сколько значащих нулей в двоичной записи чисел 48, 73, 96, 254?
5. Как по записи числа в двоичной системе счисления определить, что оно – четное? делитсяна 4? на 8? на 32?
6. Выполните сложение в двоичной системе:а) 10101112 + 1101012б) 10101112 + 1101012в) 1011012 + 111112г) 101112 + 1011102д) 1110112 + 110112е) 1110112 + 100112Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
7. Выполните вычитание в двоичной системе:а) 1011012 – 111112б) 110112 – 1101012г) 1010112 – 110112д) 10112 – 1001012 в) 101112 – 1011102 е) 10012 – 1011012Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
8. Переведите в двоичную систему числа 13,125; 23,25; 37,375; 48,625; 78,875.
9. Переведите в двоичную систему числа 11,8; 15,3; 22,7, выделив период в дробной части.
10. Требуется проверить, верно ли, что среднее арифметическое 100 целых чисел превышает0,2. Как сделать это, не используя операции с дробными числами?

Сколько единиц в двоичной записи числа 34,25?


Вы находитесь на странице вопроса "Сколько единиц в двоичной записи числа 173 ? помогите пожалуйста прошу, если тут что-то надо расписать - напишите подробно!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.