Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Вообщем так ребят. В паскале по информатике я нуб. Хоть и плюсы даются хорошо. Помогите решить одну задачу, ну или хотя бы примерно объяснить.

5-9 класс

Билет с 4-значным номером является счастливым, если сумма первых двух цифр равно сумме двух последних. Определить, является ли билет счастливым.
Спасибо^-^

Alen8012 12 янв. 2017 г., 13:54:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
денчик39рус
12 янв. 2017 г., 15:36:04 (7 лет назад)

Program pr;
uses crt;

Var a,x1,x2,x3,x4:integer;

Begin
Writeln('Введите номер билета');
readln(a);

x1:=a div 1000;
x2:=(a div 100) mod 10;
x3:=(a mod 100) div 10;
x4:=a mod 10;

if (x1+x2=x3+x4)
then Writeln('Билет счастливый')
else Writeln('Билет не счастливый');

readln;
end.

+ 0 -
Snezha2013492
12 янв. 2017 г., 16:46:24 (7 лет назад)

все что помню так это то что там нужен какой то оператор для просмотра символа, тогда переменную которую вводим делаем с типом данным стринг, а цикл должен быть через while, хотя можно сделать с помощью остатка, остатка от деления, и снова циклим, крайне лень писать програиму, но если есть вопросы задавай

+ 0 -
Nuna21
12 янв. 2017 г., 18:57:53 (7 лет назад)

хихии. У меня сейчас мозги взорвутся. В том то и дело, что полазивши по форумам я у знала что надо делать с while. А мы этого не брали:D

+ 0 -
App5u1pioqdks48
12 янв. 2017 г., 20:14:00 (7 лет назад)

Вообщем и с if можно сделать. Спасибо тебе;)

+ 0 -
MR1BooGYmaN
12 янв. 2017 г., 20:56:57 (7 лет назад)

ладно тогда с остатком от деления, смысл такой число берем с остатком от деления на 10(и получаем самое правое число), затем делим на 10(тогда тип данный реал) и все это циклим, а там снова, но уже трехзначное делим с остатком на 10, результатом будет уже третье число справа и вот у нас два числа справа для сложения, снова делим на 10 и получается двухзначное число, и тд, внутри цикла складываем что нужно и сравниваем.....

+ 0 -
Sergeifir
12 янв. 2017 г., 22:19:35 (7 лет назад)

все спасибо

Ответить

Другие вопросы из категории

1)В массиве найти все элементы больше 1 ( Паскаль)

2) в массиве из 20 элементов найти разность максимального элемента и среднего арифметического

Читайте также

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Помогите срочно! По информатике задали 7 вопрос: Возле школы растут шесть деревьев: сосна, берёза, липа, тополь, ель и клён. Какое из этих деревьев самое

низкое, если известно, что берёза ниже тополя, липа выше клёна, сосна ниже ели, липа ниже берёзы, сосна выше тополя?
И второй вопрос: Пятеро одноклассников - Аня, Саша, Лена, Вася и Миша - стали победителями школьных олимпиад по истории, математике, информатике, литературе и географии. Известно, что: 1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере; 2) Лена и Вася заинтересовались информатикой; 3) Саша всегда побаивался истории; 4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием; 5) Саша и Лена поздравили победителя олимпиады по математике; 6) Аня сожалеет о том. что у неё остаётся мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Вася, Илья, Коля, Никита и Петя решали задачи по информатике. Всего было 5 задач. Кто сколько задач решил, если известно, что: Вася и Коля решали все

задачи вместе; Петя решил на 2 задачи больше, чем Вася; Илья решил меньше задач, чем Коля; Никита решил больше задач, чем Илья, но меньше, чем Вася; каждый решил хотя бы по одной задаче.



Вы находитесь на странице вопроса "Вообщем так ребят. В паскале по информатике я нуб. Хоть и плюсы даются хорошо. Помогите решить одну задачу, ну или хотя бы примерно объяснить.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.