Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

ПАСКАЛЬ АБС! СРОЧНО! ПОМОГИТЕ ПОЖАЛУЙСТА!

10-11 класс

1. напишите программу формирования массива размером 5*5 с помощью датчика случайных чисел. Замените в нем нечетные значения элементов максимальным. Выведите на экран исходный и измененный массивы.
2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел

Serggik 11 июля 2014 г., 16:06:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vavdim966
11 июля 2014 г., 17:52:41 (9 лет назад)

1)
var a:array [1..5,1..5] of integer;
      i,j,max:integer;
begin
  randomize;
  for i:=1 to 5 do
     begin
        for j:=1 to 5 do 
          begin
            a[i,j]:=random(9)+1;
            write (a[i,j]:2);
          end;
        writeln;
     end;
  max:=a[1,1];
  for i:=1 to 5 do
    for j:=1 to 5 do
      if a[i,j]>max then max:=a[i,j];
  writeln;
  for i:=1 to 5 do
    begin
      for j:=1 to 5 do
        begin
          if a[i,j] mod 2 = 1 then a[i,j]:=max;
          write (a[i,j]:2);
        end;
      writeln;
    end;
end.

2)
var a1:array [1..5,1..5] of integer;
      a2:array [1..5] of integer;
      i,j,k,max:integer;
begin
  randomize;
  for i:=1 to 5 do
    begin
      for j:=1 to 5 do
        begin
          a1[i,j]:=random(9)+1;
          write (a1[i,j]:2);
        end;
      writeln;
      max:=a1[i,1];
      for k:=2 to 5 do
        if a1[i,k]>max then max:=a1[i,k];
      a2[i]:=max;
    end;
  writeln;
  for i:=1 to 5 do write (a2[i]:2);
end.

Ответить

Другие вопросы из категории

Перевести числа из одной системы счисления в другую:

123 (5) в ( ) (10)
1023 (4) в ( ) (10)
0,4412(5) в ( ) (10)
0,076 (8) в ( ) (10)
123(10) в ( ) (5)
149 (10) в ( ) (8)
1500 (10) в ( ) (8)
25 (10) в ( ) (2)

Проверьте пожалуйста программу.

program f_3;
var f1, f2, f3:text;
C:integer;
G:char;
s:string;
sp:string;
begin
s:=('');
sp:=(' ');
Assign(f1, 't.txt');
Assign(f2, 't2.txt');
Assign(f3, 't3.txt');
Reset(f1);
Rewrite(f2);
Rewrite(f3);
while not eof(f1) do
begin
readln(f1,G);
C:=ord(G);
writeln(f2,inttostr(C));
end;
Reset(f2);
while not eof(f2) do
begin
readln(f2,C);
G:=chr(C);
writeln(f3,G);
end;
close(f1);
close(f2);
close(f3);
end.


устройство вывода информации

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Срочно, помогите, пожалуйста

Дано число n. Из чисел от 1 до n вывести только те числа, для которых сумма делителей, не считая 1, простое число
Программа в паскале

очень срочно.....помогите пожалуйста паскаль

Определить,можно ли сделать круглую заготовку с заданным радиусом R из квадратного листа фанеры с заданной стороной А. решить ее надо с помощью оператора выбора case



Вы находитесь на странице вопроса "ПАСКАЛЬ АБС! СРОЧНО! ПОМОГИТЕ ПОЖАЛУЙСТА!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.