Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Нужно составить программу на языке программирования pascal.

5-9 класс

Даны целые числа А, В, С. Если С>=В>=А, то все числа заменить наименьшим из них, в противном случае сменить знак каждого числа.

Allagrin87 13 марта 2017 г., 10:11:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gerombo
13 марта 2017 г., 12:36:59 (7 лет назад)

var
  a, b, c: integer;

begin
  Write('Введите через пробел три целых числа: ');
  Readln(a, b, c);
  if (c >= b) and (b >= a) then begin b := a; c := a end
  else begin a := -a; b := -b; c := -c end;
  Writeln(a, ' ', b, ' ', c)
end.

Тестовое решение:

Введите через пробел три целых числа: 1 2 3
1 1 1

Введите через пробел три целых числа: 2 1 3
-2 -1 -3



Ответить

Другие вопросы из категории

2) Сообщение, записанное буквами 32-символьного алфавита, содержит 45 символов. Какой объем информации оно несет.

3) Телеграмма: Встречайте, вагон 7 содержит 4 бита информации. Сколько вагонов в составе поезда? ЗАДАЧИ НАДО РЕШАТЬ С РЕШЕНИЕМ ПОМОГИТЕ ПОЖАЛУЙСТА ЗАРАНЕЕ СПАСИБО) ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ НАДО)

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Написать программу на языке программирования Pascal.

Перевод дюймов в сантиметры (1дюйм=2,54см). Нужно, чтобы при запуске программы на экране выходило в два столбика дюймы и сколько это будет сантиметров. До 20 чисел. Через оператор While.

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



Поомогите, пожайлуста. Нужно составить программу на паскале. Ежемесячная стипендия студента составляет a руб.Расходы на проживание превышают стипендию

и составляют b руб(в месяц).Рост цен ежемесячно увеличивает расходы на 3%,составьте программу расчета необходимой суммы денег,которую нужно единовременно попросить у родителей,чтобы можно было прожить 10 месяцев,используя эти деньги.

из математической записи создать запись на языке программирования.

а)2,136+2/3y
б)(x-5)+a/3ax
Например:
Математическая запись: Запись на языке программирования:
a+3b-2c (a+3 умножить на b-2 умножить на c):(7 умножить на a+2)
Срочно!



Вы находитесь на странице вопроса "Нужно составить программу на языке программирования pascal.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.