Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

5-9 класс

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

SELI 04 авг. 2014 г., 5:23:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rainbow1337
04 авг. 2014 г., 6:54:11 (9 лет назад)

1)

#include <iostream>

 

using namespace std;

 

int main()

{

 int a[10];

 for(int i=0;i<10;i++) a[i]=rand()%36;

 for(int i=0;i<10;i++)

 {

  if(a[i]%3==0 || a[i]%2!=0)

   cout<<a[i]<<endl;

 }

system("PAUSE");

 return 0;

}

 

 

2)

#include <iostream>

 

using namespace std;

 

int main()

{

 int a[10];

 for(int i=0;i<10;i++) a[i]=rand()%100+1;

float b=0;

 for(int i=0;i<10;i++)

 {

  b+=a[i];

 }

b/=10;

cout<<b<<endl;

system("PAUSE");

 return 0;

}

Ответить

Другие вопросы из категории

Задача 16.

Спасибо, большое за вашу помощь!

Для кодирования букв А, Б,

В, Г решили использовать двухразрядные последовательные двоичные числа (от 00
до 11 соответственно). Если таким способом закодировать последовательность
символов ГБВА и записать результат шестнадцатеричным кодом, то получится: 1) 138; 2) DBCA; 3) D8; 4) 3120.

Читайте также

1)составьте программу ввода элементов массива а[1..8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2)составьте

программу ввода элементов массива b[1..6] с клавиатуры и вывода на экран элементов с положительными значемиями

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно



Вы находитесь на странице вопроса "1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.