Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Сформулировать массив из N случайных чисел от 0 до 86. Найти сумму чисел кратных 3

10-11 класс

Mouses2003 08 апр. 2017 г., 3:52:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МИНЯ83
08 апр. 2017 г., 4:54:03 (7 лет назад)

const n=10;
var a:array[1..n] of integer;
sum, i:integer;
begin
randomize;
sum:=0;
for i:=1 to n do
begin
a[i]:=random(86);
write(a[i],' ');
if (a[i] mod 3 =0) and(a[i]<>0) then sum:=sum+a[i];
end;
writeln;
writeln(sum)
end.

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99



Вы находитесь на странице вопроса "Сформулировать массив из N случайных чисел от 0 до 86. Найти сумму чисел кратных 3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.