Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В последовательности из 15 целых чисел найти максимальный элемент из четных.

10-11 класс

Помогите пожалуйста написать программу)

ЮляЮшка 21 февр. 2014 г., 5:38:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ketsenowa
21 февр. 2014 г., 6:11:31 (10 лет назад)

В цикле проверяете (a mod 2) равно ли нулю, то бишь равен ли нулю остаток. Если да - число четное. одновременно с этим первое четное число кладете в переменную max, а остальные четные сравниваете с этой переменной, если какое-то число больше - его кладете в переменную max. Ясно? Если нет, могу написать программу, но лучше чтобы вам было ясно

UPD: можно через массивы, но это не хардкорно

a, max, counter   :   integer;
begin
max := 0;
for counter = 1 To 15 Do
   begin
   writeln("Write ur number:");
   readln(a);
   if (a mod 2) = 0 then 
       if a > max then max := a;
   end;
writeln(max);
readln();
end.

–––––––––––––––––––––––––––––––––––
Вам помог Б-г

   

Ответить

Другие вопросы из категории

обнулить элементы массива B(9)

в четных ячейках . Помогите пжл , и блок схема

Pascal ABC. Помогите пожалуйста.

Срочно надо)
Вычислите:

y= x2+3x,если x<-2 корень 2x-5 ,если x≥ -2

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Задание1: В массиве из 100 случайных целых чисел найти максимальный элемент и количество вхождений этого элемента в массив. Задание2: Реализовать

простые операции с матрицами: транспонирование, умножение на число, сложение и перемножение двух матриц. Значения матриц задавать случайным образом, выбор операции предоставлять пользователю.

Помогите решить в C++

Дана последовательность из n целых чисел. Найти количество элементов этой последовательности, кратных числу К.



Вы находитесь на странице вопроса "В последовательности из 15 целых чисел найти максимальный элемент из четных.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.