Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее арифметическое

10-11 класс

чисел из последовательности

Norbert96 30 окт. 2014 г., 10:40:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Voytova1999
30 окт. 2014 г., 11:54:07 (9 лет назад)

var
  a: integer;  //a - вводимое число
  n, s: integer;  //n- количество введенных чисел, s - сумма этих чисел

begin
  n:= 0;  //обнуляем счетчик
  s:= 0;
  a:= 1;  {присваиваем значение, отличное от нуля, чтобы цикл не завершился, не начавшись}
  while a <> 0 do
  begin
    writeln('Введите целое число');
    readln(a);
    if a <> 0 then  //Чтобы при подсчете среднего арифметического не учитывался 0
    begin
      n:= n + 1;
      s:= s + a;
    end;
  end;
  writeln('Среднее арифметическое введенных чисел:  ', s / n);
end.

Ответить

Другие вопросы из категории

Помогите составить блок-схему к программе:

var x,y:real;
Begin
write('Введите х: ');
readln(x);
if (x>100) and (x<>105) then y:=sqrt(x)
else if (x=20) or (x=40) then y:=power(x,1/3)
else y:=sqr(x)+1;writeln('y=',y)
End.

Читайте также

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

33. Последовательность чисел

Вводится последовательность целых чисел, заканчивающаяся нулем. Преобразовывать последовательность следующим образом:

1) заменить отрицательные числа в последовательности на их модули и вывести получившуюся последовательность;

2) в полученной последовательности заменить четные числа на максимальное число последовательности, вывести результат;

3) в полученной последовательности вычесть из каждого члена последовательности 2, вывести результат;

4) в полученной последовательности заменить отрицательные на 0, вывести результат.



Пример.

Последовательность: 1 2 3 0

1) 1 2 3

2) 1 3 3

3) –1 1 1

4) 0 1 1

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.



Вы находитесь на странице вопроса "Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее арифметическое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.