Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать программу, которая вставляет число K в заданную возрастающую последовательность таким образом, что в результате полученная

10-11 класс

последовательность также остается полностью возрастающей.

Alsou2002 21 июня 2016 г., 22:24:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
велинта
21 июня 2016 г., 23:36:51 (7 лет назад)

var
  a: array[1..11] of integer;
  i, k, t: integer;

begin
  for i := 1 to 10 do
    read(a[i]);
  read(k);
  for t := 1 to 11 do
    if a[t] > k then break;
  for i := 11 downto t + 1 do a[i] := a[i - 1]; a[t] := k;
  for i := 1 to 11 do write(a[i], ' ')
end.

Ваша программа полностью работает и делает то, что должна делать. Проверена вставка в середину и на краях.

+ 0 -
Shevczova97
22 июня 2016 г., 2:31:12 (7 лет назад)

Комментарий удален

+ 0 -
копеечка2002
22 июня 2016 г., 3:19:31 (7 лет назад)

это уже идет углбление. от горшка достаточно знать циклы, массивы, условные операторы и пару функций библиотеки ввода/вывода.

+ 0 -
7856129
22 июня 2016 г., 5:37:17 (7 лет назад)

Комментарий удален

+ 0 -
байрам2610
22 июня 2016 г., 7:15:46 (7 лет назад)

Хероли базар устроили. Меня по человечески попросили кинуть задание....

+ 0 -
Duvd12
22 июня 2016 г., 8:05:43 (7 лет назад)

Комментарий удален

Ответить

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов



Вы находитесь на странице вопроса "Написать программу, которая вставляет число K в заданную возрастающую последовательность таким образом, что в результате полученная", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.