Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Определите количество четных элементов в последовательности, завершающейся числом 0. Само число 0, и все, что следует за ним, учитывать не нужно.

10-11 класс

Olia125 03 сент. 2016 г., 8:59:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Agashulya
03 сент. 2016 г., 10:06:13 (7 лет назад)

var i,k:byte;

begin

i:=1;

while i<>0 do begin

readln(i);

if (i<>0) and (i mod 2=0) then inc(k);

end;

writeln(k);

end.

Ответить

Другие вопросы из категории

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1. Вычисляются два числа

– сумма первых трёх цифр и сумма последних трёх цифр.2. Полученные два числа записываются друг за другом в порядке неубывания (без разделителей).Пример. Исходное число: 15177. Поразрядные суммы: 7 ,15. Результат: 715.Определите, сколько из приведённых ниже чисел могут получиться
в результате работы автомата.

Читайте также

Система команд исполнителя Ластик имеет вид:

(Умножение на 2),(Стереть последнюю цифру)
A) числа 7 из числа 361:
Б) числа 14 из числа 457:

1.Одномерный массив заполнен случайным образом. Найти количество четных элементов. 2. Одномерный массив размерностью N , где N -нечетное число,

заполнен случайными числами от -15 до 6. Все , числа кратные 3 заменить на противоположные.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.



Вы находитесь на странице вопроса "Определите количество четных элементов в последовательности, завершающейся числом 0. Само число 0, и все, что следует за ним, учитывать не нужно.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.