Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

нужно написать программу по паскалю: сформировать массив из десяти элементов.элементы могут иметь положительные,отрицательные и нулевые

5-9 класс

значения.посчитать количество положительных,отрицательных и нулевых элементов.

Klimovamothert 13 дек. 2016 г., 1:56:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinasmachnyh
13 дек. 2016 г., 2:42:58 (7 лет назад)

var a:array [1..100] of integer;
i,n,plus,minus,zero:integer;

Begin
  randomize;
  n:=10;
  for i:= 1 to n do begin
    a[i]:=random(n*10)- 10*n div 2 ;
    write(a[i]:4);
    if i mod 10=0 then writeln;
  end;
 
  for i:= 1 to n do begin
    if a[i]<0 then plus:=plus+1;
    if a[i]>0 then minus:=minus+1;
    if a[i]=0 then zero:=zero+1;
  end;
    
  writeln(plus, minus, zero);
 
End.

Ответить

Другие вопросы из категории

*в клетку электронной табл. можно занести: а)только формулу в)только число или текст с)только число д)число,формулу или текст е)диаграмму Диопоз

он клетки эл. табл.-это.. а)множество клеток,образующих область произвольной формуле в)множ. заполненных клеток ЭТ с)множ. пустых кл. ЭТ д)множ. кл.,обазующ. область квадр. формы

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так : цифры, занимающие чётные разряды (нумирация разрядов ведеся справо налево н

ачиная с нуля) , циклически сдвигаются вправо , а нечетные - влево на количество позиций, равных номеру разряда. Так, например циклический сдвиг цифры 7 на четыри позиции вправо дает нам 1 ( 7-8-9-0-1). Затем из нечетных цифр вычитается , а к четным прибавляется 1. Далее оба шага повторяются еще один раз. В результате шифровки получилось число 3216. Определите пароль.

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Электрическая цепь составлена изЭлектрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б.

Нужно написать программу в Паскале.
Между А и Б сопротивление
R1, R(общее R2, R3), R4 соединены последовательно, а R2 и R3 параллельно.
Т.е. общее сопротивление равно..
R=R1+(R2*R3)/(R2+R3)+R4
на основании этой формулы нужна программа.

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"



Вы находитесь на странице вопроса "нужно написать программу по паскалю: сформировать массив из десяти элементов.элементы могут иметь положительные,отрицательные и нулевые", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.