Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите сделать программу на паскале:

10-11 класс

Встречается ли внутри слова его первая буква

Алия41 06 авг. 2015 г., 17:22:18 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Deniska2012
06 авг. 2015 г., 20:22:15 (8 лет назад)

program detector;

var  s: string;
        l: byte;
begin 
   write('Введите слово: '); 
   readln(s);  l := length(s); 
   if l < 2 then 
      writeln('Введите корректное слово!') 
   else 
   begin   
      while (l <> 1) and (s[l] <> s[1]) do 
         begin     
             s := copy(s, 1, l - 1);     
              l := length(s);   
         end; 
    if l = 1 then       
       writeln('Буква не встречается повторно!') else 
       writeln('Буква встречается повторно!'); 
    end;
end.

Ответить

Другие вопросы из категории

Определить значение целочисленной переменной а и b после выполнения фрагмента программы:

a:=2599;
b:=(a mod 10)*1000+26;
a:=(b div 10) mod 100;

1) a=26, b=9026; 2) a=2, b=9026; 3) a=26, b=9926; 4) a=2, b=9926.

Заполнить массив из 10 элементов случайными числами в интервале [0...10] и выполнить циклический сдвиг массива ВПРАВО.

Формат ввода и вывода данных:
Исходный массив:
4 -5 3 10 -4 -6 8 -10 1 0
Результат:
0 4 -5 3 10 -4 -6 8 -10 1

Читайте также

Помогите создать программу на паскаль:

Разработать
программу в соответствии со своим вариантом: создать структуру типа «запись», выполнить
обработку данных.

Привет всем. Помогите написать программы на паскале.

Сами задачи во вложении.

Помогите написать программу на паскаль и блок схему

Найти сумму
1,1-1,2+1,3.......1.n
n- целое, вводится с клавиатуры



Вы находитесь на странице вопроса "Помогите сделать программу на паскале:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.