Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана строка. Найдите в этой строке второе вхождение буквы f, и выведите индекс этого вхождения. Если буква f в данной строке встречается только один раз,

5-9 класс

выведите число -1, а если не встречается ни разу, выведите число -2

Linylik2001 28 марта 2017 г., 11:53:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
стадничук
28 марта 2017 г., 14:50:18 (7 лет назад)

var
f:char;
s:string
i.k:integer;
begin
readln(f,s);
k:=0;
for i:= 1 to length(s) do begin
if s[i]=f then k:=k+1;
if k=2 then writeln(i);
end;
if k=1 then writeln("-1");
if k=0 then writeln("-2");
end.

Ответить

Другие вопросы из категории

люди подскажите что изучается в информатике.

P.S. У кого был планшет digma optima 7.1 пожалуйста ответьте: как вы получили root права на планшет то никак не получается много прог перепробовал.

Читайте также

Дана некоторая строка . Из нее создают вторую строку по следующему алгоритму:

1. Сначала вторая строка пуста
2.Затем каждый символ первой строки от первого до последнего приписывается к создаваемой(второй) строке слева , если это гласная буква и ее позиция в исходной строке была нечетной , или если это согласная буква и ее позиция была четной. Во всех остальных случаях очередной символ первой строки приписывается ко второй строке справа . По этому алгоритму строка ВОЦА превратилась в строку ОВЦА .
А какая строка превратилась в строку ИНАВОРИГОРПРАМЕ ??

Синвейн про информатику

(1 строка информатика
2 строка два прилагательных
3 строка три глагола
4 строка фраза, несущая определённый смысл
5 строка вывод в одном слове)
Стоки не должны рифмоваться

1. Запишите определение алгоритма, вставив пропущенные слова:«Алгоритм – это … и … предписание исполнителю выполнить … последовательностькоманд,

приводящую к … ».2. Структура алгоритма, все команды которого выполняются по очереди только один раз,называется:а) Линейной.б) Ветвящейся.в) Циклической.г) Рекурсивной.3. Свойство алгоритма содержать только те команды, которые понятны исполнителю,называется:а) детерминированностью;б) массовостью;в) понятностью;г) однозначностью.4. Как называется свойство алгоритма, в котором отражено четкое разделение шагов и ихпоследовательное выполнение:а) однозначность;б) результативность;в) понятность;г) дискретность.5. Как называется алгоритмическая конструкция, в которой, в зависимости от условий,может выполняться либо одно, либо другое действие?а) Линейной.б) Ветвящейся.в) Циклической.г) Рекурсивной.6. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виделинии. В каждый конкретный момент известно положение исполнителя и направление егодвижения. У исполнителя существуют две команды:Вперед n, где n – целое число, вызывающая передвижение черепашки на n шагов внаправлении движения.Направо m, где m – целое число, вызывающая изменение направления движения на mградусов по часовой стрелке.Запись Повтори 4 [Команда 1 Команда 2] означает, что последовательность команд вквадратных скобках повторится 4 раза.Черепашке был дан для исполнения следующий алгоритм:Повтори 4 [Вперед 10 Направо 120]Какая фигура появится на экране?1) незамкнутая ломаная линия в) квадрат2) правильный треугольник г) правильный пятиугольникПримечание: сумма внешних углов правильного n-угольника равна 360 градусов.7. Определите значение переменной а после исполнения алгоритма.а:=6b:=22-3*aa:=b/2*aПорядок действий соответствует правилам арифметики. В ответе укажите только одно число.8. Определите значение переменной b послевыполнения алгоритма, записанного в видеблок-схемы:Примечание: знаком := обозначенаоперация присваивания. В ответе укажитеодно число – значение переменной b.9. У исполнителя Калькулятор две команды, которым присвоены номера:1. прибавь 22. умножь на 3Первая из них увеличивает число на экране на 2, вторая – утраивает его. Запишитепорядок команд в алгоритме получения из числа 1 числа 31, содержащем не более 5команд, указывая лишь номера команд (например 22211).10. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующимобразом. Сначала записывается исходная цепочка символов, после нее записываетсябуква, стоящая в исходной цепочке на первом месте, затем записывается исходнаяцепочка символов в обратном порядке. Получившаяся цепочка является результатомработы алгоритма. Например, если исходная цепочка символов была ЛЕС, то результатомработы алгоритма будет цепочка ЛЕСЛСЕЛ.Дана цепочка символов ЗУ. Какая цепочка символов получится, если к данной цепочкеприменить алгоритм дважды (то есть к данной цепочке применить алгоритм, а затем крезультату его работы еще раз применить алгоритм)?11. На бесконечном поле имеется бесконечная стена. Робот (Р) находится над стеной исмотрит вправо. Написать алгоритм, который переведет Робота в первую клетку подстеной (к.с.).Рк.сПримечание: команды, которые умеет выполнять Робот, узнайте у преподавателя.



Вы находитесь на странице вопроса "Дана строка. Найдите в этой строке второе вхождение буквы f, и выведите индекс этого вхождения. Если буква f в данной строке встречается только один раз,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.