Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

С клавиатуры вводится целое число не превышающее 2 миллиарда.заменить четные цифры на 0. Срочно нужна помощь.

10-11 класс

вОл4ёК 20 февр. 2014 г., 18:25:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ДианОk
20 февр. 2014 г., 18:58:00 (10 лет назад)

Easy
var
i:integer;
s:string;
begin
readln(s);
for i:=1 to length(s) do if (s[i]='2') or (s[i]='4') or  (s[i]='6') or (s[i]='8')  then s[i]:='0';

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Играют двое.Первый участник игры называет произвольное целое число, не превышающее десяти.Второй игрок прибавляет к названнаму числу свое целое число,

тоже тоже не превышающе десяти, и сообщает новой сумму.К новой сумме второй прибавляет число и т.д. до тех пор, пока окончательной суммой не окажется число 100. Выигрывает тот, кто первым достигнет 100. Как должен действовать первый игрок, чтобы выиграть.

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.



Вы находитесь на странице вопроса "С клавиатуры вводится целое число не превышающее 2 миллиарда.заменить четные цифры на 0. Срочно нужна помощь.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.