Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

10-11 класс

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Udita1 18 окт. 2014 г., 0:13:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Doroha
18 окт. 2014 г., 2:54:26 (9 лет назад)

type
mass = array[1..6,1..3] of real;
var nam:mass;
a,i:integer;
begin 
for i:=1 to 6 do    for a:=1 to 3 do begin   
if a = 1 then nam[i,a]:=random(90)+10;     
if a = 2 then nam[i,a]:=round(sqrt(nam[i,1]))     
else nam[i,a]:=nam[i,2]+nam[i,1];     
end;                   
for i:=1 to 6 do begin 
for a:=1 to 3 do     
write (nam[i,a],'  '); 
writeln; 
writeln
end;    
end.

Ответить

Другие вопросы из категории

Написать блок-схему для задачи:

Если в заданную строку символов входит каждая из букв слова KEY, тогда напечатать YES, иначе - NO.

Читайте также

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

ПОМОГИТЕ ПОЖАЛУЙСТА!!! МОЖНО ТОЛЬКО ПРОГРАММУ. НЕ МОГУ РАЗОБРАТЬСЯ КАК СДЕЛАТЬ...

Составить программу на Паскале (желательно и выполнить).
С клавиатуры ввести 10 элементов массива (целые числа). Вывести исходный массив. Заменить элементы на противоположные и вывести получившийся массив (в строку).

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите пожалуйста!!!!

Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0



Вы находитесь на странице вопроса "Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.