Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1 В зависимости от того что вводится с компьютера программа должна посчитать площадь треугольника по одной из двух формул S=1/2 основания на h либо по форм

10-11 класс

уле Герона

2 В зависимости от номера класса введенного с клавиатуры вывести на экран что это начальная, средняя, старшая или выпускное звено. Выпускное звено 9 и 11 классы.

Tata3178 13 дек. 2014 г., 7:50:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Temik0000
13 дек. 2014 г., 8:22:25 (9 лет назад)

как-то так var a,b,c,h,p,s:real; var ch:char; var f:boolean;
begin
repeat
write('Êàê ñ÷èòàåì ïëîùàäü? 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: ');
readln(ch);
if ch='1' then begin
write('a='); read(a); write('b='); read(b); write('c='); read(c);
p:=(a+b+c)/2; s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Ïëîùàäü ðàâíà ',s); f:=true;
end
else if ch='2' then begin
write('a='); read(a); write('h='); read(h);
writeln('Ïëîùàäü ðàâíà ',0.5*h*a);
f:=true;
end
else begin cls; writeln('Îòâåò ôèãîâûé! Åùå ðàçîê: 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: '); end;
until f;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста

Выпишите целые десятичные числа, принадлежащие промежуткам:

a) [1011012; 1100002]

b) [148; 208]

c) [2816; 3016]

Ребят, помогите решить первые 10 заданий. Информатика, логика.

Даю 25 баллов, но если будет решены все 10.

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Читайте также

1) Сколько следует задать вопросов и как их следует формулировать, чтобы количественно оценить сообщение о том, что вагон стоит на одном из 16 путей?

2) Вы бросаете два кубика с нанесенными на гранях цифрами от 1 до 6. Определите, сколько битов информации несет сообщение о том, что на одном кубике выпала тройка, а на другом- пятерка.
3) Предположим, вероятность того, что вы получите за контрольную работу оценку "5", равна 0,6; вероятность получения "4" равна 0,3; вероятность получения "3"-0,1. Определите, сколько битов информации будет нести сообщение о результатах контрольной работы в каждом из вариантов. ПОЖАЛУЙСТА, ПОМОГИТЕ!!!

ПОМОГИТЕ РЕШИТЬ ЗАДАЧКИ!!!! На ферме из 12 коров 3 больные. Какова вероятность того, что из 4 выбранных наудачу коров 1 больная?

Из 15 арбузов 3 неспелых. Какова вероятность того, что из 3 вы- бранных арбузов 2 спелых?

Среди 10 доноров 4 имеют первую группу крови. Какова вероятность того, что из 2 наудачу выбранных доноров один имеет первую группу крови?

Помогите составить программу

В зависимости от того введена ли открытая скобка или закрытая, напечатать "открытая круглая скобка" или "закрытая фигурная скобка".(учитывать круглые , квадратные,фигурные скобки)



Вы находитесь на странице вопроса "1 В зависимости от того что вводится с компьютера программа должна посчитать площадь треугольника по одной из двух формул S=1/2 основания на h либо по форм", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.